Skipping stuttering sound

Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Skipping stuttering sound
PostPosted: Thu Oct 18, 2007 1:13 am 
Not Signed Up For Stats

Joined: Thu Oct 18, 2007 1:07 am
Posts: 1
I am running on Ubuntu 7.10, using Gnome and the latest openal drivers. The game is running great except that the sounds skip and stutter. I have also tried running the game through aoss and that doesn't seem to work. The sound works fine in other applications.

Does anyone know how I might be able to fix this? I didn't find any answers in the FAQ.


Top
 Profile  
 
 Post subject: Re: Skipping stuttering sound
PostPosted: Thu Oct 18, 2007 4:39 am 
User avatar
Obliterated

Current Scorched3D Rank: Unranked








Joined: Wed Feb 16, 2005 1:26 am
Posts: 1591
Location: Some Where On Earth I Think
Gyxer wrote:
I am running on Ubuntu 7.10, using Gnome and the latest openal drivers. The game is running great except that the sounds skip and stutter. I have also tried running the game through aoss and that doesn't seem to work. The sound works fine in other applications.

Does anyone know how I might be able to fix this? I didn't find any answers in the FAQ.


What sound card? What do you have under sound preferences?
Image
"Always do right. This will gratify some people and astonish the rest."
Mark Twain


Top
 Profile  
 
 Post subject:
PostPosted: Sat Oct 20, 2007 5:14 pm 
Not Signed Up For Stats

Joined: Sat Oct 20, 2007 5:09 pm
Posts: 1
It took me ages to find a fix, but this worked in the end:
echo "(define devices '(sdl))" > ~/.openalrc
Source: http://icculus.org/lgfaq/#ut2k3badsnd


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 21, 2007 4:17 pm 
User avatar
Desintigrated

Current Scorched3D Rank: Unranked






Joined: Sat Jun 12, 2004 12:53 am
Posts: 2890
Location: _____________________________ Current Scorched3d Rank: 1 _____________________________ *clink*
For reference, here's my .openalrc:
Code:
# Contains user settings for OpenAL
# Goes in ~/.openalrc

# Use ALSA (also valid: sdl, native)
(define devices '(sdl))

# Four speaker surround with ALSA
(define speaker-num 4)
(define alsa-out-device "surround40:0,0")
#(define speaker-num 2)
#(define alsa-out-device "hw:0,0")
~


With this I get lovely 4 channel sound.

I should put a note in the Wiki about this... it crops up now and again.

cbx

*Edit - added a note in the Wiki http://www.scorched3d.co.uk/wiki/index.php/Openalrc *
To be honest, I don't fully understand that page, but it sounds like it provides the answers you need. - Deathstryker

She doesn't stimulate me mentally or physically... I need at least one of those - Anonymous

Who wrote this crap? - G. Camp


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © phpBB Group