Forum Replies Created

Viewing 9 posts - 256 through 264 (of 264 total)
  • Author
    Posts
  • in reply to: i’ll help #32384

    parasti
    Participant

    @nomoresteve wrote:

    By all means, feel free to change the colors! 😉

    Nobody’s going to change them.

    in reply to: FR: FPS limiter #32294

    parasti
    Participant

    @gcamp wrote:

    The game uses openal-config to get the libs line, it looks like an issue whith that non-scorched provided file.

    Not sure it’s an issue. ALUT is not part of OpenAL. (At least not anymore?)

    in reply to: FR: FPS limiter #32292

    parasti
    Participant

    @raskolnikov wrote:

    I already knew that the problem was in the linking fase, but I don’t know whether it’s Scorched’s fault or it’s my system’s fault. Maybe the ./configure is wrong or something like that.

    I just tried to build the game myself and got the same error. It’s the game’s fault. Looks like no checks for ALUT libraries are performed except those of the compiler itself. A temporary fix: add ‘-lalut’ to LIBS in ./src/scorched/Makefile, line 1679.

    in reply to: new forum color/style? #32373

    parasti
    Participant

    I’m all for it.

    in reply to: Debian package didn’t work for Kubuntu #32366

    parasti
    Participant

    @lithium wrote:

    So for the RPM converted to Deb, the game posed no problems for you on exit? Do I still need that libwsGTK2.4 package?

    None and yes.

    Edit: actually, I just checked, and the binary does not appear to be dynamically linked with libwxgtk, so maybe that part of my reply is not true.

    in reply to: Debian package didn’t work for Kubuntu #32364

    parasti
    Participant

    @lithium wrote:

    NM. I followed what someone else did who had the same problem. I used apt-get to load the libwx2.4 package and the game runs. However, every time I exit a game, a window pops up saying Scorched3d terminated unexpectedly. I’ve tried game safe-mode settings and still have the same problem. My NVIDIA card is using the latest glx driver posted on the NVIDIA sight and other OPENGL games work fine. What’s wrong?

    Okay, since you updated the post while I was replying, I might as well try to answer this one. 🙂 I had the same problem and am now using the provided RPM converted to the Debian format by ‘$ fakeroot alien package.rpm’ (needs the fakeroot and alien packages).

    in reply to: Debian package didn’t work for Kubuntu #32363

    parasti
    Participant

    @lithium wrote:

    I am new to Ubuntu and the whole Debian packaging scheme. I downloaded and installed the Scorched3d 4.0 debian package and installed it. When I run scorched 3D, I get a message saying:

    scorched3d: error while loading shared libraries: libwx_gtk-2.4.so.1: cannot open shared object file: No such file or directory

    I don’t know what this means but I’m running a 2.6 version of the kernel. I’m not sure if installing libwx 2.4 (whatever that is) is a good idea or not and I’m not even sure loading libwx will help. What do I need to do?

    wxWidgets is the GUI drawing kit that the game uses. You will need to install libwxgtk 2.4. Take a look at the Kubuntu Desktop Guide for some more or less useful information on package management.

    in reply to: FR: FPS limiter #32290

    parasti
    Participant

    @raskolnikov wrote:

    Parasti, how can I set Vsynch in Scorched? That would be a nice and easy solution 🙂

    I believe that depends on what kind of video board you’re using. For instance, if you’re using an NVIDIA like me, you’d either set the __GL_SYNC_TO_VBLANK environment variable to a non-zero value or (the simple way) use the nvidia-settings utility and modify the OpenGL settings. But really, check the documentation of your graphics driver.

    Moreover, I was trying to build scorched but, despite I have development packages of OpenAL and Alut installed, I get this:

    ../sound/SoundBufferStaticWav.cpp:80: undefined reference to `alutLoadWAVFile'
    ../sound/SoundBufferStaticWav.cpp:96: undefined reference to `alutUnloadWAV'
    ../sound/SoundBufferStaticWav.cpp:80: undefined reference to `alutLoadWAVFile'
    ../sound/SoundBufferStaticWav.cpp:96: undefined reference to `alutUnloadWAV'

    I can only tell that it fails the linking phase. Headers are found and are valid but not the library files (usually located in /usr/lib/).

    in reply to: FR: FPS limiter #32288

    parasti
    Participant

    Why don’t you just use vertical synchronization?

Viewing 9 posts - 256 through 264 (of 264 total)