Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: Problems linking to libjpeg #45791

    drumz
    Participant

    I recompiled wxGTK with –enable-compat24 and then tried again. Now it works.

    Thanks for the help!

    in reply to: Problems linking to libjpeg #45790

    drumz
    Participant

    I did some more checking and I had wxWidgets and wxGTK installed. Come to find out they’re the same thing so I removed both of them and am reinstalling/compiling wxGTK and will then recompile scorched3d. I have a 1.3GHz Pentium-M, so this could take awhile…

    in reply to: Problems linking to libjpeg #45788

    drumz
    Participant

    I managed to get it to compile by wrapping the include statement for jpeglib in an extern “C” statement.
    Change the following in src/GLEXT/GLJpg.cpp:


    extern "C" {
    #include
    }

    As mentioned it now compiles and I installed it. However, when I try to run it I get the following error:

    $ scorched3d
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6),
    and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6).
    Aborted

    I suspect the wxGTK 2.8 fix I applied from http://www.scorched3d.co.uk/phpBB2/viewtopic.php?t=4699 wasn’t enough.

Viewing 3 posts - 1 through 3 (of 3 total)