Forum Replies Created

Viewing 15 posts - 1 through 15 (of 51 total)
  • Author
    Posts
  • in reply to: hmm… #12082

    Chomsky
    Participant

    Hmm, didn’t mean to create a new thread, I was responding RE the possible new ‘official’ scorched update.

    How embarrassing! 🙄

    in reply to: Poor sound quality in Linux #11829

    Chomsky
    Participant

    Great fix, cbx!
    😀

    in reply to: OSX Port? #11030

    Chomsky
    Participant

    @jspoon wrote:

    Any word on the Mac package now that a) the weekend is officially over and b)v37.1 is out?

    Sorry, I’ve been busy with school stuff. I’ll get something out soon. I might have to abondon my docked app loader and make people run this from an xterm again, but the release will happen regardless.

    c. thoma

    in reply to: OSX Port? #11026

    Chomsky
    Participant

    Well, the program itself is compiled but the launcher app I created for it is exhibiting some strangeness.

    You might have to wait until the weekend, sorry.

    Also, just to be cantankerous, I’ll point out that it’s still ‘today’.

    :p

    @anonymous wrote:

    *looks at clock*

    COME ON, WHAT’S THE HOLD UP?!?!

    j/k 😉

    in reply to: OSX Port? #11024

    Chomsky
    Participant

    Hi folks, the port of v37 should be out some time tomorrow.

    -chomsky

    in reply to: some ideas for new features #9855

    Chomsky
    Participant

    I was thinking of perhaps a new weapon which opened in midair revealing dozens of mushroom-shaped paratroopers.

    The remainder of the game could center around jumping on top of said ‘troopas’, and fighting large lizards in order to rescue a princess.

    in reply to: mac os x problems #10914

    Chomsky
    Participant

    @soundsmurf wrote:

    I am running mac os x on a 17″ powerbook. I’ve installed the x11 app. But when I launch scorched it runs but all the graphics are messed up and the screen seems to be shifted off a little. Anyone got any ideas??? I would love to get this game running. However I’m the first to admit I a little technically challenged.

    Thanx for any help.

    Please turn off OpenGL extensions in the display options. Also, you may want to set all options to the settings which would be easiest on your GPU (small textures etc)….

    In our experience, this solves most display problems.

    in reply to: Mac OS Help #10861

    Chomsky
    Participant

    @jspoon wrote:

    @chomsky wrote:

    Did you reach a verdict, or is the jury still out?

    Yes, er, sorry it got lost in there. I did reach a verdict.

    It was the box marked ‘don’t use texture details.’ It came prechecked. When I was unchecking things, I unchecked this too, then got confused because I assumed the problem would be solved by turning something off, not turning it on.

    And this was on the machine with a geforce 4 mx, correct? Not the powerbook? (which vid card does your PB use, BTW?)

    in reply to: Mac OS Help #10860

    Chomsky
    Participant

    Gavin,

    This is a really minor point, but it seems odd that the error message only goes to stdout when the display resolution cannot be used.

    Your dialogMessage() function seems to have the capability of creating a wxgtk popup window. Perhaps this is yet another wxgtk inadequacy on OSX?

    in reply to: Mac OS Help #10858

    Chomsky
    Participant

    Hi,

    I read your post, but I’m still unclear on why this preferences ‘magic’ was happening.

    Did you reach a verdict, or is the jury still out?

    Very happy that you found the installer useful 🙂

    c. thomas

    in reply to: Mac OS Help #10854

    Chomsky
    Participant

    Gavin,

    This sounds kind of interesting… he’s reporting that the artifacts went away when he unchecked everything and then went back and rechecked it all….

    Could you theorize as to what could cause this behavior?

    @jspoon wrote:

    Thanks, I tried this. I turned everything off or down and it worked just fine. Then I went back and turned all the options back one row at a time and it still worked. Huh? I can think of two possibilities:

    1. First I thought maybe I got confused and clicked a check box more or less times than I thought I did. This would be easy because, as I said before, I have trouble with these silly check boxes.

    2. Then I thought back to my initial problem with the resolution. In that problem, the graphics were set by default to 1280×854 even though that wasn’t an option on the list. Maybe one of those other settings was set by default to something that is represented by neither a checked box nor an unchecked one. Just a possibility.

    Anyway, it’s a great game and I’m glad I got it working. When I get home tonight I’ll get X11 on my powerbook and install it on that too. Should be good fun.

    Thanks again for the help.

    in reply to: Mac OS Help #10852

    Chomsky
    Participant

    @jspoon wrote:

    Ok, I figured out the fullscreen problem. I reread the error message and noticed as I should have noticed before that it said it was trying to go at a resolution of 1280×854 which my monitor doesn’t do. I went to display options and saw 1024×768 was the highest resolution on the pop up and that should work. I therefore tried changing it to 800×600 and back to 1024×768. This worked-now it operates full screen at my highest resolution. Still messed up though, I’ll get back to you if I figure out anything about the graphics problems.

    Start off by disabling all of the ‘bells and whistles’ and setting it to the lowest detail settings you can get, for all kinds of textures. Disable OpenGL extensions and any other things you can.

    This usually gets rid of most problems.

    After you’ve gotten your screen to look nicer, you can start re-enabling things one by one to see how far you can go without the problems coming back.

    Future OSX installation packages for scorched3d will include as defaults very very low system requirement settings, and then people can experiment with fancy stuff by themselves.

    Hope this helps…

    C. Thomas

    in reply to: Mac OS X 10.3.2 Illegal instruction #10871

    Chomsky
    Participant

    @goochrules! wrote:

    Its a shame wxgtk is so broken.

    Amen to that, Gooch. I downloaded the development version of wxmac (cocoa widgets) to evaluate it for linking into the next version of scorched…. they haven’t even implemented a lot of the basic widgets yet. We’ll be on gtk for a while.

    in reply to: Mac OS Help #10849

    Chomsky
    Participant

    Please write back detailing your the complete hardware configuration (especially video) on your computer as well as the OS version number.

    btw, you can run scorched3d from a window by typing

    /usr/local/games/scorched3d/scorched3d

    into the application called xterm which is run by the X11 program.

    Good luck, and welcome to the world of unix.

    [/code]

    in reply to: Mac OS X 10.3.2 Illegal instruction #10867

    Chomsky
    Participant

    I’d agree with what the fink developers told you…. I think this is a gcc issue, and not a scorched3d one.

Viewing 15 posts - 1 through 15 (of 51 total)