This topic contains 0 replies, has 0 voices, and was last updated by  imported_gcamp 10 years ago.

  • Author
    Posts
  • #5918

    Brain Damage
    Participant

    wxwidgets 2.8 breaks compatiblity with 2.4 series unless compiled with special flags (most common distros doesn’t use such option)

    we can either drop 2.4 compatibility (wich is more than 2 years old & i would recomend) or wrap the depricated code in #ifdef

    wxnotebooksizer is depricated since wx2.6, instead any other sizer would do the same task

    fix for 2.8 compatibility

    src/wxdialogs/SettingsDialog.cpp@446:

    	wxBoxSizer *nbs = new wxBoxSizer(wxVERTICAL);
    nbs->Add(book_);

    src/wxdialogs/DisplayDialog.cpp@108:

    	wxBoxSizer *nbs = new wxBoxSizer( wxVERTICAL );
    nbs->Add(book_);
    #45573

    imported_gcamp
    Participant

    Thanks BD added to CVS.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.