This topic contains 9 replies, has 0 voices, and was last updated by  jdog 10 years, 10 months ago.

  • Author
    Posts
  • #5263

    jdog
    Participant

    Do projectile and there counterparts get to use ambient, diffuse, specular, and emissive lighting from MilkShape3d?

    The picture below shows the my new rollers in game 🙁 and in milkshape.

    Left picture is in game and right picture is in milkshape.

    You can see the differences in how they look.

    #38963

    cbx550f
    Participant

    @jdog wrote:

    Do projectile and there counterparts get to use ambient, diffuse, specular, and emissive lighting from MilkShape3d?

    The picture below shows the my new rollers in game 🙁 and in milkshape.

    Left picture is in game and right picture is in milkshape.

    You can see the differences in how they look.

    Wow – those do look crappy in the game. Scorched does use all of those with the exception of specularity (correct me if I’m wrong here).

    Try cranking up the ambient and diffuse up to about 0.8

    HTH

    #38964

    jdog
    Participant

    I got all four, of all four, cranked up to 255 of 255.

    #38965

    cbx550f
    Participant

    @jdog wrote:

    I got all four, of all four, cranked up to 255 of 255.

    Does that result in the values showing up as 1.0 in the resulting .txt file? (Not sure – I’ve never used MilkShape) The values are between 0 and 1 in the .txt

    Edit: Also, do they have a texture image?

    #38966

    jdog
    Participant

    @cbx550f wrote:

    @jdog wrote:

    I got all four, of all four, cranked up to 255 of 255.

    Does that result in the values showing up as 1.0 in the resulting .txt file? (Not sure – I’ve never used MilkShape) The values are between 0 and 1 in the .txt

    Edit: Also, do they have a texture image?

    I think it does, never really looked in the file to look at that part, just texture paths. ( I have all of the 4 lightings to max in milkshape.)

    Yes it does have textures. Right picture the two 32×32 pictures, one is marked spike and the other is marked body.

    #38967

    InductiveOne
    Participant

    Open a model that looks ok ingame in milkshape, check the material settings. There is something (I can never remember what) that you have to set right or everything looks all washed out. Also, try opening the milkshape.txt model in a text editor and going to the bottom, you will see your textures there. Compare them to a few working .txt models and you will see which you need to change there (change them in the text editor then reopen in milkshape).

    #38968

    jdog
    Participant

    Did some tests and far as I can tell, the game ignores lighting settings for projectile models. 🙁

    #38969

    jdog
    Participant

    I also just realized that sphere mapping seems be ignored on the spikes too.

    #38970

    Bobirov
    Participant

    @jdog wrote:

    I also just realized that sphere mapping seems be ignored on the spikes too.

    Dunno if you’re aware, but the milkshape ASCII format doesn’t support sphere mapping. You have to manually edit the file and change the texture name so that S3D will use sphere mapping on that texture. Just add sphere_ to the beginning of the texture name you want to sphere map and Scorched3D will use it. If it supports it on projectiles that is.

    #38971

    jdog
    Participant

    @bobirov wrote:

    @jdog wrote:

    I also just realized that sphere mapping seems be ignored on the spikes too.

    Dunno if you’re aware, but the milkshape ASCII format doesn’t support sphere mapping. You have to manually edit the file and change the texture name so that S3D will use sphere mapping on that texture. Just add sphere_ to the beginning of the texture name you want to sphere map and Scorched3D will use it. If it supports it on projectiles that is.

    DOH! Thanks for reminding me that. I remember now Gavin telling us this.

    #38972

    jdog
    Participant

    Using sphere_ on the texture fixed it and it looking good.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.