This topic contains 6 replies, has 0 voices, and was last updated by  Panther30 9 years, 12 months ago.

  • Author
    Posts
  • #5950

    Panther30
    Participant

    Hi everyone,

    I have a small issue with Scorched not wanting to log stats again, but I am using my old mysql.xml files to do so. I am missing the port information for mySQL I am running Linux (fedora core 5)) and I am unsure how to find the mysql port information. what do I do?

    #45810

    Bobirov
    Participant

    @panther30 wrote:

    Hi everyone,

    I have a small issue with Scorched not wanting to log stats again, but I am using my old mysql.xml files to do so. I am missing the port information for mySQL I am running Linux (fedora core 5)) and I am unsure how to find the mysql port information. what do I do?

    Add this to the mysql file:

    3306

    #45811

    Panther30
    Participant
    - Created mysql stats logger.
    Mon Oct 22 15:16:55 2007 - mysql stats logger failed to start. Error: Can't connect to local MySQL server through socket '3306' (2)
    Mon Oct 22 15:16:55 2007 - mysql params : host localhost, user Anonymous, passwd , db Scorched3d
    Mon Oct 22 15:16:55 2007 - Player connected dest="0" id="9000000" name="(Beast)Kota" unique=[VIOLATOR - computer - 1]
    Mon Oct 22 15:16:55 2007 - mysql stats logger failed to start. Error: Can't connect to local MySQL server through socket '3306' (2)
    Mon Oct 22 15:16:55 2007 - mysql params : host localhost, user Anonymous, passwd , db Scorched3d

    This iis the error part of what I see in terminal when I run scorched as a server.

    #45812

    Bobirov
    Participant

    Err, its a bit different on linux, forgot about that. Try this instead of port 3306.

    /var/lib/mysql/mysql.sock

    #45813

    Panther30
    Participant

    okay that did the trick. Thank you.

    Now there is one more thing but Ill have to test it myself. I’m having hte “can’t connect to my own game server through my router” issue again. but I know wny: The cable router I am temprarily using as a switch between my room and the office is known to have an issue. it will have to be replaced before I can play.

    #45814

    The AI
    Participant

    heh, then it looks like we will all have to get on to keep the server warm for you. Great to see panthermod go 41.

    #45815

    Bobirov
    Participant

    @panther30 wrote:

    Now there is one more thing but Ill have to test it myself. I’m having hte “can’t connect to my own game server through my router” issue again. but I know wny: The cable router I am temprarily using as a switch between my room and the office is known to have an issue. it will have to be replaced before I can play.

    I discovered a little ‘bug’ of sorts after v41 release that if you happen to be playerid #1 in the stats database, it won’t let you play basically. You can only connect and it goes straight to the score. Its been changed now though. Just be aware that if you are playerid #1 on your own server, you’ll need to either move your stats to a different player id or rebuild your client with the playerid change.

    If you’re not playerid #1 in your database, then just ignore all that. 😉

    #45816

    Panther30
    Participant

    yeah Im not player Id number 1. None of my computers on this switch or on the wireless in the office can connect. I beleive that hte problem is the switch. but there is one more option I can try. I will let you know how it goes.

    problem is solved. I had to forward both for incoming and outgoing on both ports the scorched servers need forwarded. Everything is working now. I alos went ahed and replaced a problematic router with one that is pci card (you heard right) in my server until I can get a new external one.

    thanks again

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.