This topic contains 21 replies, has 0 voices, and was last updated by  yusuf 9 years, 1 month ago.

  • Author
    Posts
  • #6616

    Laptops Daddy
    Participant

    hi,

    wanted to test the new lua thing. seems there are some issues with gcc 4.3 (http://gcc.gnu.org/gcc-4.3/porting_to.html)

    i made a bit of a sketchy patch:

    Index: src/common/lua/loslib.cpp
    ===================================================================
    --- src/common/lua/loslib.cpp (revision 94)
    +++ src/common/lua/loslib.cpp (working copy)

    ...and so on
    (removed - some of it no longer applies)

    which is cool. seems to compile ok now, but all I get when I run scorched3dc is a black frozen scorched window.

    little help please?

    ps: i dont think theres a pinguine flavoured _stricmp. think we need strcasecmp. (not that id know. lower-case string comparisons or something)

    #53265

    Laptops Daddy
    Participant

    im told this might help:

    main (argc=1, argv=0xbfdfbc74) at ./main.cpp:60

    doesnt mean a lot to me, though, im afraid. configuration file of some kind missing, perhaps?

    #53266

    imported_gcamp
    Participant

    Not tried running on linux recently but it should compile and run out of the box. I’ll have a look when I get home.

    Is the gcc 4.3 the standard now?

    #53267

    PeanutsRevenge
    Participant

    @gcamp wrote:

    Not tried running on linux recently but it should compile and run out of the box. I’ll have a look when I get home.

    Is the gcc 4.3 the standard now?

    Well if my Suse 11.0 is anything to go by, yes, gcc 4.3 is the standard.

    #53268

    Laptops Daddy
    Participant

    @gcamp wrote:

    Not tried running on linux recently but it should compile and run out of the box. I’ll have a look when I get home.

    thanks
    @gcamp wrote:

    …Is the gcc 4.3 the standard now?

    youre asking me?! i really wouldnt know : ). i had help with the above. debian lenny comes with 4.3.1. http://gcc.gnu.org/ lists 4.3.2 as current.

    guess i could probably compile with 3.4. gonna be more of an issue in time though, i guess.

    #53269

    Irishbandit
    Participant

    I don’t know I have 3.3 4.1 and 4.2 and it compiles fine under ubuntu 8.04.

    #53270

    imported_gcamp
    Participant

    It’s occured to me that you are probably running off the trunk, which although sounds like a good idea probably isn’t. Have you changed to the heightmap branch?

    cd /opt/src
    svn co https://scorched3d.svn.sourceforge.net/svnroot/scorched3d/trunk scorched3d
    svn switch https://scorched3d.svn.sourceforge.net/svnroot/scorched3d/branches/heightmap scorched3d/scorched/
    #53271

    Laptops Daddy
    Participant

    Thanks for the reply. Yes. Svn is quite new to me, but I’m pretty sure I downloaded the right code. It was v42 I was interested in.

    I installed gcc/g++ 4.2 this morning and it compiled ok without the patch. ( ‘./autogen.sh CC=gcc-4.2 CXX=g++-4.2’). But I still have the same issue.

    Screenshot:

    If it helps, I’m Debian Lenny, NF4, 6800GT SLI with 173.14.09.

    Ps:
    I tested with v41 from the trunk before making the original post. It still needed a patch for 4.3, but ran normally.

    Pps:
    if (0 == stricmp(rule->getName(), nameValue.valueString.c_str())): ). ‘_’

    #53272

    Exiled One
    Participant

    I am sorry but are guys in someway updating your download package because from today on I tried installing the new version of scorch and I am getting errors. Not sure if its the same problem as lappy tappy’s but I am getting a NSIS Error not sure what that is?

    I means it says, it might have a virus or is it a firewall problem. I cant determinate it. I downloaded it 3 to 4 times now not sure what wrong with it. I am not quite sure if its the same problem as laptops.

    I am using a university lab computer that always reboots deleting everything each day and I install each day for the past few days and it worked but today its giving me errors.

    Sorry, If I posted my reply in the wrong spot.

    #53273

    imported_gcamp
    Participant

    The download has not been updated for a while now.

    #53274

    Exiled One
    Participant

    Sorry Gavin, just now I downloaded again and I looked into the properties and saw an option says to unblock things from another computer and that did the trick. Thanks for reply. Sorry…I didnt know they would have such a option in properties. Problems been taken care off.

    Thanks.

    #53275

    Thrax
    Participant

    @Exiled One wrote:

    Sorry Gavin, just now I downloaded again and I looked into the properties and saw an option says to unblock things from another computer and that did the trick. Thanks for reply. Sorry…I didnt know they would have such a option in properties. Problems been taken care off.

    Thanks.

    try copying the installed folders to a usb thumb-drivve. it should load cleanly on any windows os. if you wan’t mods, save them in the /data/globalmods to have hem carried with you.

    #53276

    imported_gcamp
    Participant

    I was just about to suggest that, or burn them to a CD. It should work equally well off that.

    #53277

    imported_gcamp
    Participant

    Try now Laptops. I’ve changed a few things that may help.

    #53262

    Laptops Daddy
    Participant

    @gcamp wrote:

    Try now Laptops. I’ve changed a few things that may help.

    awesome. fixed! thank you very much.


    buoys everywhere! and is it me or are the shadows fixed?

    looking forward to testing it properly.

    thanks again

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.