This topic contains 14 replies, has 0 voices, and was last updated by  Panther30 9 years, 11 months ago.

  • Author
    Posts
  • #5990

    Thrax
    Participant

    For the last week+, Panther has been trying to get his hosted server
    to play stable. But we keep getting a crash that boots you instantly.

    He runs Linux and has tried to compile it himself following the exact
    directions available, and using the propper updates listed for a current
    working build.

    He has tried everything possible to cure any network failures and we can
    find no connection-related reason for the error, so we are asuming it’s in
    the build.

    The error happens thus.. On connecting to the game-server and loading
    the map, the buy screen appears as usual. If you buy no weapons, the
    menu closes, and play begins. But if you buy any weapons, it will Dump
    when you press the Ok giving us this error-screen.

    It only happens on his server, i can connect to all others flawlessly.
    He has tried every possible way to compile for linux and the build has
    always played fine local.. only crashing as a hosted-server.

    Are there any other Linux members that have tried to self-build and
    host for thier friends?

    #46089

    Panther30
    Participant

    ahh found something that might help me solve the issue and I have a couple of questions

    even when installing the rpm package for scorched 41 I get a bunch of unresolved dependencies dealing with libwx_gtk2u-2.8

    now i have compiled wxGTK 2.8 several times with the –enable-unicode support. my question is:

    when compiling wxGTK, what is the full command line I need to use?

    and

    could this poor compile of wxGTK be the reason Scorched is not installing from the package distro and also failing to compile from the source code correctly?

    hoping someone can help,

    —Panther30

    #46090

    a banana
    Participant

    @panther30 wrote:

    ahh found something that might help me solve the issue and I have a couple of questions

    even when installing the rpm package for scorched 41 I get a bunch of unresolved dependencies dealing with libwx_gtk2u-2.8

    now i have compiled wxGTK 2.8 several times with the –enable-unicode support. my question is:

    when compiling wxGTK, what is the full command line I need to use?

    and

    could this poor compile of wxGTK be the reason Scorched is not installing from the package distro and also failing to compile from the source code correctly?

    hoping someone can help,

    —Panther30

    I had to downgrade to wxGTK v2.6 to compile – just totally couldn’t get it going with 2.8. Brain Damage covered the wxwidgets issue in this thread.

    It also involved editing the two files (from the source code) that BD talks about.

    Whether that’s going to actually fix the problem you’re having is a different question, though…

    What Linux distro are you using?

    a banana

    #46091

    imported_gcamp
    Participant

    Shouldn’t be wx related, wx isn’t used at all by the server. Run while allowing exceptions and give us a stack trace, perhaps that will shed some light on it.

    #46092

    Panther30
    Participant

    Linux distro is Fedora Core 6

    I editied both lines that BD talks about for my last scorched compile.

    I will compile 41.1 and see if it gives me the errors.

    #46093

    Panther30
    Participant

    the errors that the rpm gave me

     rpm -ivh Scorched3D-41.1.i386.rpm
    error: Failed dependencies:
    libwx_baseu-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_baseu-2.8.so.0(WXU_2.8) is needed by scorched3d-41.1-1.i386
    libwx_baseu_net-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_baseu_xml-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_adv-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_adv-2.8.so.0(WXU_2.8) is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_aui-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_core-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_core-2.8.so.0(WXU_2.8) is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_html-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_qa-2.8.so.0 is needed by scorched3d-41.1-1.i386
    libwx_gtk2u_xrc-2.8.so.0 is needed by scorched3d-41.1-1.i386
    [root@localhost share]#
    #46094

    Panther30
    Participant

    gavin, here’s your stack:


    /usr/bin/scorched3d -allowexceptions
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6),
    and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6).
    Aborted
    [server1@localhost ~]$
    #46095

    PeanutsRevenge
    Participant

    ditto on mandriva 08 One

    #46096

    Irishbandit
    Participant

    @panther30 wrote:

    ahh found something that might help me solve the issue and I have a couple of questions

    even when installing the rpm package for scorched 41 I get a bunch of unresolved dependencies dealing with libwx_gtk2u-2.8

    now i have compiled wxGTK 2.8 several times with the –enable-unicode support. my question is:

    when compiling wxGTK, what is the full command line I need to use?

    and

    could this poor compile of wxGTK be the reason Scorched is not installing from the package distro and also failing to compile from the source code correctly?

    hoping someone can help,

    —Panther30

    Have you tried using the fedora7 wxGTK-2.8.3-2.fc7.i386.rpm?
    ftp://rpmfind.net/linux/fedora/extras/development/i386/wxGTK-2.8.3-2.fc7.i386.rpm

    #46097

    PeanutsRevenge
    Participant

    Compiled fine for me after downgrading as mentioned from 2.8 – 2.6, didnt have to use the display/settings.cpp editing either.

    Runs SOOO much sweeter then 41 too

    #46098

    Panther30
    Participant

    Irish, it seems to work in single player on my game server, the oly way I know to test if my server works is to wait for people to connect. If they can play without getting kicked after buying items for a couple rounds. I will know for sure that your fix did the trick.

    for anyone interested, I had to get the wxGTK-devel package as well as the file in Irish’s post for this to work.

    thanks a bunch Irish,

    —Panther30

    #46099

    Irishbandit
    Participant

    @panther30 wrote:

    Irish, it seems to work in single player on my game server, the oly way I know to test if my server works is to wait for people to connect. If they can play without getting kicked after buying items for a couple rounds. I will know for sure that your fix did the trick.

    for anyone interested, I had to get the wxGTK-devel package as well as the file in Irish’s post for this to work.

    thanks a bunch Irish,

    —Panther30

    I am just happy it worked. 🙂

    edit–
    Just played a couple of rounds with Paris every-thing seems to be working. 😀 😀

    #46100

    Panther30
    Participant

    on the server labeled Panther’s Server (the one in the list just below the Headoff servers)?

    thrax got two rounds in on that server (which is mine) and got kicked probably with the error he poseted above. I will leave that server and Falcon’s server up for a day or two to test. Create a new threed to report any issues with those servers.

    solution to connection problems found:

    the connection problem everyone is having is in my network. THere is either a bad line or a bad network switch. I will leave a note in my panther’s server thread when I have it solved. for now, my servers are down.

    #46101

    Panther30
    Participant

    AHA!

    I installed the rpm for version 40.1d and ran that version of Panthermod. It was reported that the game ran smooth with no kicks for the plyer who tried the server (that would be thrax).

    now I guess i will try downgrading wsGTK from 2.8 to 2.6 this week. I will let you know if i can get scorched to compile or not.

    —Panther

    #46102

    cbx550f
    Participant

    If that doesn’t do it (just now saw this thread), I might suggest just compiling scorched using “./configure –enable-serveronly -prefix=/usr/local/scorcheds” (Just setting the prefix to separate it from the client build/install) and try running the server from that.

    Run it with -allowexceptions, and then if it crashes, post the core dump (you may have to do “ulimit -c unlimited” on the commandline first to allow it to write a core file)

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.