This topic contains 51 replies, has 0 voices, and was last updated by  Sih 10 years, 2 months ago.

  • Author
    Posts
  • #31029

    Simwiz
    Participant

    Hi,
    I have had moderate success in following the instructions that oopsz wrote about. Unfortunately, I have encountered an error when running the make command as follows.

    checking for SDL_net lib… no
    configure: error: *** Can’t find the SDL_net library Try: http://www.libsdl.org/projects/SDL_net

    I went to the site suggested and I downloaded and copied the sdl-net into my /library/framework/ folder, but it still will not find the sdl-net. Am I doing something wrong? Everything up to this point seems to work fine.

    I am running a macbook with OSX 10.4.10.

    Simwiz

    #31030

    Ben Urban
    Participant

    @simwiz wrote:

    I went to the site suggested and I downloaded and copied the sdl-net into my /library/framework/ folder, but it still will not find the sdl-net. Am I doing something wrong? Everything up to this point seems to work fine.

    Yes. You are trying to use the GNU Autotools with frameworks. Configure scripts can’t detect installed frameworks, and the script for Scorched3D doesn’t allow someone to specify the location of all the required libraries that are set up as frameworks on Mac OS X.

    The alternative that the Scorched3D developers recommend is to install Fink and install the required libraries through that. Obviously, that is a less-than-ideal solution, though it does work.

    Recently, I created a Scorched3D project file for XCode, and have successfully used it to compile a standalone application bundle. You can find the XCode files, as well as the source code patch, earlier in this thread.

    #31031

    Simwiz
    Participant

    Thanks for the help Ben,
    Unfortunately, i have tried fink, but with little success. I am using fink commander (I am a code noob), and the only sdl packages that come up when I search are: sdl, sdl-image, sdl-mixer, sdl-shlibs, sdl-ttf, and sdl-ttf-shlibs. I have installed all of those through fink, but I guess they aren’t enough. (on a side note, I did try command line installing sdl-net, and I got an error “no matching version found for sdl”.

    So, since I am unable to go the route using fink (unless someone has an idea), I would rather go with the xcode route. However, I am a complete noob to xcode and making .app files. So, would you be able to give me some noob instructions as to how I go about using the two files you have for me?

    I really appreciate the help guys, and I am learning as I go.

    p.s. Ben- if you wanted to dropload (or similar) the completed file to me, my e-mail is simwiz@shaw.ca (that might be easier than giving instructions?)

    #31032

    Ben Urban
    Participant

    I suspect the command-line compilation of SDLnet is failing because it can’t find sdl-config, because Fink puts everything in /sw, and you probably don’t have /sw/bin in your $PATH. It’s possible that you can get it to work by telling it to look in /sw/bin, but I think the XCode route would be better.

    First, you will need to obtain and install the following frameworks:

    FreeType.framework
    Ogg.framework
    SDL.framework
    SDL_net.framework
    Vorbis.framework

    The project expects them to be in /Library/Frameworks.

    You will also need the Scorched3D source distribution; I used version 40.1d. You can unpack it wherever you want; I used the Desktop. (I will refer to the scorched folder as $SRCROOT.)

    Of course, you will also need to obtain and unpack the two files I provided.

    1. Apply the patch to the source distribution using the patch command in the Terminal, like so:

    cd $SRCROOT
    patch -p1 < /path/to/Scorched3D-40.1d.osx.diff

    It should apply cleanly without any problems.

    2. Move the project files into the osx folder in the distribution. You should now have the following items in $SRCROOT/osx:

    English.lproj
    Info.plist
    SDLmain.h
    SDLmain.m
    Scorched3D.xcodeproj
    alut.h
    island.icns
    tank2.icns
    wxgtk.info
    wxgtk.patch

    3. Open $SRCROOT/osx/Scorched3D.xcodeproj, make sure the active build configuration is set to Release (Project->Set Active Build Configuration->Release), and build it (Command-B), or build it and run it (Command-R). You will get a large number of warnings about unused variables, as well as some deprecation warnings; for now, these can be ignored.

    4. You can find Scorched3D.app in $SRCROOT/osx/build/Release. Put it wherever you like, or run it from there.

    If you encounter any problems with the process, please let me know.

    #31033

    Simwiz
    Participant

    So, I eventually found the vorbis, ogg, and freetype frameworks (go http://www.submedia.net/uqm/, and http://www.kyngchaos.com/software/unixport/frameworks for those who are wondering)

    I got these installed, patched the source with your patch, but when I go to build the file, I get 45 errors (most can be seen on the screenshot I attached). I am not thinking these are the errors you were talking about, since the build fails rather than completes.

    I took a screenshot of most of the errors, there are a few further up that I couldn’t fit on the screen.

    Thanks so much for the help… I am so close I can almost taste Intel native Scorched!

    #31034

    Ben Urban
    Participant

    It looks like you do not have SDL and SDL_net installed. You can find them at http://www.libsdl.org/.

    If any of the items are in red in the project window, that means those files do not exist where they were expected to be found. This is correct behavior for Scorched3D.app before it is built, but there shouldn’t be anything else in red.

    #31035

    Simwiz
    Participant

    I figured out that ImageStore.cpp and Mesh.cpp are the two files that contain the errors, in case that helps.

    #31036

    Simwiz
    Participant

    I checked the project window and I originally had the ogg.framework and vorbis.framework being shown red, but once I found and installed them, xcode can see them.

    As to sdl and sdl-net being installed, I put both of those frameworks into the library/frameworks folder (same with ogg, vorbis, and freetype frameworks). I can browse to them in finder, so I don’t understand why xcode can’t find them. Is there something else I should try? Something special I need to do to install the frameworks properly (other than drag and drop them to the specified folder)?

    #31037

    Simwiz
    Participant

    Ben,
    Is there any way you would be able to create a torrent of the .app file you got working? I have tried to create it myself on both my macbook and my i-mac, but the build just fails. Or, is there a way to get schorched3d.org to host it since it is a different version than the ppc specific one on their website?

    #31038

    Ben Urban
    Participant

    I could host a torrent, but I’d rather not, given a better option. I have not looked into getting the .app hosted on scorched3d.org, and I don’t have the time to do so right now. If you’d be willing to find out about that for me, I’d appreciate it.

    #31039

    parasti
    Participant

    @ben Urban wrote:

    scorched3d.org

    Don’t go there.

    #31040

    imported_gcamp
    Participant

    I can host a binary here (scorched3d.co.uk) if you want/need.

    #31041

    Simwiz
    Participant

    schorched3d.org

    What I meant to say was scorched3d.co.uk
    sry for the confusion.

    Gcamp, thanks for the offer. Is there a link that Ben can go to in order to U/L the file? Or.. What is the process for getting the app onto your website?

    #31042

    Ben Urban
    Participant

    I just realized…
    Since the other Scorched3D binaries are already hosted on SourceForge, I may as well upload it directly to their FTP upload directory, to make things a lot easier. Any reason not to do that?

    What would you like the file’s name to be? (It’s a ZIP file)

    #31043

    imported_gcamp
    Participant

    I guess the file name should start similary to those already distributed at http://sourceforge.net/project/showfiles.php?group_id=85144 e.g.

    Scorched3D-40.1d-something

Viewing 15 posts - 16 through 30 (of 53 total)

You must be logged in to reply to this topic.