This topic contains 13 replies, has 0 voices, and was last updated by  h4ngedm4n 14 years ago.

  • Author
    Posts
  • #2222

    Arcanica
    Participant

    I am running Linux Redhat 9. I installed the game via RPM. I keep getting the stupid “Display : ERROR: Failed to set the display mode” error. I swiched to 24bit mode and I still get this error. Any Help?

    #9737

    imported_gcamp
    Participant

    24bit mode worked for me!

    Do you have an accelerated X driver installed?

    #9738

    Anonymous
    Participant

    Yeah I get this error, too. I’m running Gentoo Linux at 16bit 1600×1200, and no matter what I do it just says that.

    #9739

    redzebra
    Participant

    ok 2 things :

    1) for the the one running in 16 bit : you should be running at 24.
    try changing it in /etc/X11/XF86Config

    2) if your running at 24 bits :
    try running one of these and tel me whats the output :glxgears,glxinfo,xvinfo

    – alternativly you might try different things : like in the scorched data directory
    there’s a file called display.xml
    and some entries like
    DepthBufferBits
    24
    24

    try putting both at 16

    – red.

    #9740

    Anonymous
    Participant

    I am having the same problem with Failed to set display mode. Here is the output of glxgears/glxinfo/xvinfo

    $glxgears
    800 frames in 5.0 seconds = 160.000 FPS
    800 frames in 5.0 seconds = 160.000 FPS
    800 frames in 5.0 seconds = 160.000 FPS

    $glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    client glx vendor string: SGI
    client glx version string: 1.2
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    OpenGL vendor string: Mesa project: http://www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.3 Mesa 4.0.4
    OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat


    0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
    0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
    0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
    0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
    0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None

    $xvinfo
    X-Video Extension version 2.2
    screen #0
    Adaptor #0: “Matrox G-Series Backend Scaler”
    number of ports: 1
    port base: 61
    operations supported: PutImage
    supported visuals:
    depth 24, visualID 0x23
    depth 24, visualID 0x24
    depth 24, visualID 0x25
    depth 24, visualID 0x26
    depth 24, visualID 0x27
    depth 24, visualID 0x28
    depth 24, visualID 0x29
    depth 24, visualID 0x2a
    number of attributes: 4
    “XV_COLORKEY” (range 0 to 16777215)
    client settable attribute
    client gettable attribute (current value is 66046)
    “XV_BRIGHTNESS” (range -128 to 127)
    client settable attribute
    client gettable attribute (current value is 0)
    “XV_CONTRAST” (range 0 to 255)
    client settable attribute
    client gettable attribute (current value is 128)
    “XV_DOUBLE_BUFFER” (range 0 to 1)
    client settable attribute
    client gettable attribute (current value is 1)
    maximum XvImage size: 1024 x 1024
    Number of image formats: 4
    id: 0x32595559 (YUY2)
    guid: 59555932-0000-0010-8000-00aa00389b71
    bits per pixel: 16
    number of planes: 1
    type: YUV (packed)
    id: 0x32315659 (YV12)
    guid: 59563132-0000-0010-8000-00aa00389b71
    bits per pixel: 12
    number of planes: 3
    type: YUV (planar)
    id: 0x30323449 (I420)
    guid: 49343230-0000-0010-8000-00aa00389b71
    bits per pixel: 12
    number of planes: 3
    type: YUV (planar)
    id: 0x59565955 (UYVY)
    guid: 55595659-0000-0010-8000-00aa00389b71
    bits per pixel: 16
    number of planes: 1
    type: YUV (packed)

    #9741

    Anonymous
    Participant

    I get same message on Gentoo Linux(X11 with NVidia drivers and depth 24). And option DepthBufferBits is not in display.xml. If I add this option to file. I am geting this:


    Scorched3D Options : ERROR: Failed to parse file "/usr/share/games/scorched3d/data/display.xml". Cannot find option "DepthBufferBits"
    #9742

    blah
    Participant

    Hi,

    Same error for me too, running gentoo.
    Display 1280×1024 @ 24 bit depth.
    intel i810

    #9743

    DeVice
    Participant

    I think the part that says :

    direct rendering: No

    means that you don’t have 3D done by hardware, but rather a software emulation (done by Mesa).

    You may want to google a bit about how to add hardware 3D acceleration support to XFree, according to your video card brand/model.

    #9744

    imported_gcamp
    Participant

    Nvidia provide a very good accelerated linux driver but you need to download it from their website. If you use the default XFree one it does NOT make use of the accelerated features on the card.

    As for the intel and other cards I don’t know where to get an accelerated version of the driver. Perhaps the intel site…

    #9745

    Anonymous
    Participant

    I have direct rendering, but it is probably unrelated to this problem anyway. This software should still work with software rendering, but more slowly. The issue is that we cannot open a window in scorched’s display mode.

    #9746

    zphelj
    Participant

    I get the same error. I also tried a few variations such as ScreenDepth in display.xml without success. Is there a way to specifiy screen depth in display.xml?

    Also, is there any way to get more information than “Display: ERROR: Failed to set the display mode” ???

    #9747

    imported_gcamp
    Participant

    Ok, I have made a few changes to try help this situation:-

    o ALL of the video settings are now available via the config file.
    o The error information displayed is a lot more comprehensive
    o The mode asked for is less strict (it seems that we were asking for hardware everthing).

    These changes are now in the development version and should be out in version 36.

    #9748

    DeVice
    Participant

    Note on your changes : I was previoulsy able to run the game with a display in 16bpp mode, now i have to set it to 24bpp, otherwise the game’s borking at me.
    May not be going the way you intended it to 🙂

    #9749

    imported_gcamp
    Participant

    Tell me about it three problems with 36 already 😮

    You may be able to run in 16bbp if you change the number of bits used for each color and alpha to 4.

    #9750

    h4ngedm4n
    Participant

    I have the same problems as the folks above. I tried changing DepthBuffer to 16bpp but am still getting the same error. That being said, I also have DRI working so DRI is definately not the issue. My card is a matrox g450 and well supported in X. I am running slackware linux 9.1.

    Also I notice when building scorched3d, both version 36 and cvs, the Makefile in src/scorched is missing a -L/usr/X11R6/lib in order to include libGL.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.