This topic contains 8 replies, has 0 voices, and was last updated by  mandy 11 years, 3 months ago.

  • Author
    Posts
  • #4160

    eroeurbano
    Participant

    Hi, I read many of the threads in this forum about this argument, but I still can’t cope with it!

    I would like to start my own server to play with my friends.
    I opened all the port that are mentioned in the guide,
    and the starting server operation seems to succed.
    Anyway, when I go in the JOIN GAME menu, I can’t see my server name,
    but only the ip address (not my private ip, the public one)
    If I try to join my own server, the connection fails.
    How can I do to start a server and play with my friends?

    Can you give me some help!

    I’m sorry for my bad English, but I’m Italian and I can’t speak it very well!

    I’ll be grateful with any of you that can give me help!

    #26645

    Brain Damage
    Participant

    english:
    are you behind a firewall? if yes, you have to open the inbound port that lets the server to work (the port which the server is opened at); if you use windows xp, you might have the OS’s firewall turned on wich block incoming connections by deafult.

    italiano:
    stai utlizzando una firewall? se si, devi aprire la porta in ingresso che permette al server di funzionare (la porta su ciu è aperto il server); se stai usndo windows xp, potresti avere la firewall integrata abilitata che blocca le connesioni in ingresso per default.

    #26646

    eroeurbano
    Participant

    English: I opened all the ports that need to be opened!
    I was able to play connecting to lan game…

    Italiano: le porte necessarie le ho aperte…
    alla fine sono riuscito a giocare i oconnettendomi al gioco
    nella lan e i miei amici connettendosi all’indirizzo ip che gli do io…
    però mi sembra una soluzione un po’ forzata…

    Thanks for you advice!!!
    Grazie mille per i consigli!!!

    #26647

    Brain Damage
    Participant

    english:
    i’ve just switched to an adsl router modem, and the same problem occurred to me, the ip was showed but i could not join nor having server name diplayed.
    i’ve solved it by going into the settings of my router and forwarded the following ports:
    tcp/27270 (my server port)
    udp/27271 (still used by server)
    udp/27393 (tracker server port, the port used to send server’s info)
    now works perfectly and ppl can join it by the connect screen
    EDIT: you can’t connect to your server using your expernal ip address (the 1 showed in the list of internet server), you have to use your internal LAN address, to see it just click “refresh LAN games” instead of clicking “refresh internet games”, then you can play in your own server

    italiano:
    ho appena preso un nuovo modem router adsl e ho avuto anch’io il tuo problema, l’ho risolto entrando nel pannello di controllo del router e ho settato in forwarding le seguenti porte:
    tcp/27270 (la porta del mio server)
    udp/27271 (un’altra porta usata dal server)
    udp/27393 (questa è usata dal server che tiene traccia degli altri)
    ora funziona perfettmente e la gente può collegarsi tramite l’interfaccia connetti
    MODIFICA: non puoi collegarti al tuo stesso server utilizzando il tuo indirizzo ip esterno (quello mostrato nella lista dei server in internet), devi utilizzare il tuo indirizzo interno alla LAN, per vederlo, premi “refresh LAN games” invece di “refresh internet games”, e potrai giocare nel tuo stesso server

    #26648

    jdog
    Participant

    Brain Damage

    english:
    i’ve just switched to an adsl router modem, and the same problem occurred to me, the ip was showed but i could not join nor having server name diplayed.
    i’ve solved it by going into the settings of my router and forwarded the following ports:
    tcp/27270 (my server port)
    udp/27271 (still used by server)
    udp/27393 (tracker server port, the port used to send server’s info)
    now works perfectly and ppl can join it by the connect screen

    I hope this solves my problem too!

    #26649

    Hollowpoint
    Participant

    That’s helpful. However, my brother and I are operating off of one network. Is there any way to forward ports to two places at once? Further, is there any way to forward through DHCP (which causes variable IP addresses)? Thanks…

    Also, how does one set up a LAN game?

    #26650

    Deathstryker
    Participant

    LAN game is pretty much the same as setting up an internet game only you wouldn’t want to publish the IP (setting = Allow ALL other internet users to see and use this server) , or internet users would see it listed.

    And then when you go to find it, you refresh LAN games instead of internet games. That’s pretty much all there is to it.

    #26651

    Brain Damage
    Participant

    there should be one solution to do dynamic ip NAT translation wich is called uPnP (universal plug ‘n play), wich despites it’s name, it’s a network related protocol, that protocol lets you set your router to forward certain ports to another pc if the pc asks those ports by request, uPnP must be supported by the router, and usually is turned off by defaul because of security reasons (check out: http://www.grc.com/UnPnP/UnPnP.htm ) because some virus may use the upnp to open ports in your router and give your pc access to the world, after you read that article and you are still on you mind to use it, you can use it by those steps:

    if you are using windows xp the internal firewall has a upnp feature integrated, it means that when you open a port in that firewall, it will be requested to open in the router as well trought upnp and automatically forwarded to that computer.
    go to your connections panel
    select properties of your lan connection
    turn on the firewall
    set as allow incoming ports the one i listed before
    now it should work, to make sure, click on the server list page ( http://www.scorched3d.co.uk/servers.php ) and make sure that your server is listed

    there are also few programs over the net (i used to have 1 but i lost the link) that lets you forward your ports using the upnp protocol

    #26652

    Hollowpoint
    Participant

    Thanks, but apparently that wasn’t actually the problem…
    My firewall (ZoneAlarm) blocked access even when it wasn’t active. But it’s fixed now.

    #26653

    mandy
    Participant

    german 😉

    english 😉

    italiano 😉

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.