This topic contains 29 replies, has 0 voices, and was last updated by  parasti 9 years, 11 months ago.

  • Author
    Posts
  • #6222

    kowal
    Participant

    fisrt sorry if i post this on the wrong forum.

    i just rebuild s3d couple days ago (make an RPM and debuginfo package) but the game keeps randomly crashed on me. sometime i can play 1 game without problem, sometime can’t even finished 1 round.

    i asked BD two days ago, and he gave me some guidance.
    so i installed the debuginfo package, now i have 2 error log & 1 segmentation fault.

    the s3d_crash_output_1.txt generated after i play couples of round trying to catch the random crash, but since it was not happening so i quit the game in normal fashion and i get this error.
    then BD told me to try ticking the no sound option -> save the setting -> and run scorched3dc directly from konsole. i do that, the game loaded without problem, but when i choose a server and clicked Join Game it gave me segmentation fault error.

    then, as BD suggested, i untick the no sound setting. run scorched3dc and play the game (no segmentation error here) 1 or 2 rounds and this time the random crash happens. catched the error on s3d_crash_output_2.txt.

    thanks.

    #48786

    naka
    Participant

    I’m not sure if that is related to your problem, but i still have random FREEZES on ATI/fglrx drivers with water on.

    When i turn water off the game run normal.

    #48787

    kowal
    Participant

    wow, already turned off almost everything. i’ll try that. thanks.

    anyway these are my settings.

    #48788

    Mcb Lover
    Participant

    LOL Kowal…that was hi-tech 😛

    #48789

    kowal
    Participant

    @naka
    turned off the water. the random crash seems to not happened anymore, but who knows 🙂 i give it two days. i’ll report back with the result then.

    but the segmentation fault still there when i ticked the no sound option.

    btw, kinda sucks playing with no water 😆

    @vitos
    yeah..
    when i found this game was kinda hoping this game wouldn’t need a super duper computer just to enjoy a 3d game. was kinda true before this 41 version. 🙂 but no complaint here 🙂
    and btw, ati cards suck on linux. don’t buy them 👿

    #48790

    kowal
    Participant

    nope, still crashed mid game 😥

    i already turned off everything. don’t know what else to do.
    i guess i have to wait for the next ati-driver release

    #48791

    kowal
    Participant

    running s3d with this command:

    $scorched3dc -allowexceptions

    after a while it crashes mid game with this error

    $scorched3dc -allowexceptions
    Segmentation fault
    #48792

    Laptops Daddy
    Participant

    Have you tried running fullscreen in desktop resolution?

    Can you run glxgears, fgl_glxgears without problems?

    Would it help to post xorg.conf?

    I’m no linux expert you know (‘specially with the pretty versions : ), didn’t read your output, but in case it helps…

    What version or xorg does Suse 10.3 use? (is that what you said you were in?). And what ATI driver release?

    #48793

    kowal
    Participant

    @laptops Daddy wrote:

    Have you tried running fullscreen in desktop resolution?

    no, haven’t tried that. i’ve always play in windowed mode. so when you kill me in the 1st move i can move s3d window to another screen and do something else. 😉
    @laptops Daddy wrote:

    Can you run glxgears, fgl_glxgears without problems?

    yep, no problems there. been playing with other 3d games too (true combat elite, spring, freespace 2, and other quake 3 based games) without problems. this crashing thing only happens with scorched3d.
    @laptops Daddy wrote:

    Would it help to post xorg.conf?

    umm dunno, gonna post that when i’m home.
    @laptops Daddy wrote:

    I’m no linux expert you know (‘specially with the pretty versions : ), didn’t read your output, but in case it helps…

    What version or xorg does Suse 10.3 use? (is that what you said you were in?). And what ATI driver release?

    xorg 7.2
    ati catalyst 7.12 (8.443.1), btw IIRC the last time i play this game i was using ati 8.40.

    btw, peanuts also using suse 10.3, but he had nvidia card. man i wish bought an nvidia back then 😥

    oh btw, last nigh i’ve tried ticking all the options on the compability settings (kinda frustated in this part 🙂 ). tried playing with the no sound setting, and boom it works, no segmentation fault. but i haven’t done much test, too sleepy. gonna do some more testing this night.

    #48794

    kowal
    Participant

    ok after i selected all the options on the compability settings, the segmentation fault which happens if i select no sound seems to be fixed.

    after i turned off water, no random crash (yet).

    but when i played with gulas (just before i make this post), i suddenly disconnected with a box came out sait lost packet (that UDP thingy). but my konsole said segmentation fault.

    now i’m confuse… 😕 😕 😕

    this is my current settings:

    i can almost hear peanuts laughing & say “sucks to be you”. bah.

    and this is my xorg.conf

    # /.../
    # SaX generated X11 config file
    # Created on: 2007-10-26T23:45:40+0700.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer , 2005
    # Contact: SaX-User list
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/opt/kde3/share/fonts"
    FontPath "/usr/local/share/fonts"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "IgnoreABI" "on"
    Option "AIGLX" "true"
    EndSection

    Section "Module"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "extmod"
    Load "glx"
    Load "v4l"
    Load "dri"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImPS/2 Logitech Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    DisplaySize 386 290
    HorizSync 30-96
    Identifier "Monitor[0]"
    ModelName "M991"
    Option "DPMS"
    VendorName "DELL"
    VertRefresh 50-160
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    # Modeline "1024x768" 94 1024 1072 1168 1376 768 769 772 808 -hsync -vsync
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1024x768" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "800x600"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "RV350 AS"
    BusID "2:0:0"
    Driver "fglrx"
    Identifier "Device[0]"
    Option "Capabilities" "0x00000000"
    Option "ScreenOverlap" "0"
    Option "mtrr" "off"
    Option "ForceGenericCPU" "no"
    Option "GammaCorrectionI" "0x00000000"
    Option "no_accel" "no"
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "GammaCorrectionII" "0x00000000"
    Option "no_dri" "no"
    Option "VideoOverlay" "on"
    Option "PseudoColorVisuals" "off"
    Option "StereoSyncEnable" "1"
    Option "UseInternalAGPGART" "no"
    Option "DesktopSetup" "Horizontal"
    Option "ForceMonitors" "auto,crt1"
    Option "Mode2" "1024x768,1024x600,800x600,768x576,640x480"
    Option "OpenGLOverlay" "off"
    Option "Stereo" "off"
    Option "CenterMode" "off"
    Option "XAANoOffscreenPixmaps" "true"
    Option "Textured2D" "true"
    Option "TexturedXrender" "true"
    Option "FSAAEnable" "off"
    Option "FSAAScale" "0"

    VendorName "ATI"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "DAMAGE" "true"
    Option "Composite" "true"
    EndSection

    #48795

    PeanutsRevenge
    Participant

    Yea, I didnt have crashing on my 10.3 and Nvidia, however 95% of the time when quitting the game, I’d get a popup about the game crashing and did I want to use safemode.
    Never had problems mid game, even with full effects straining the card at about 7fps

    #48796

    kowal
    Participant

    turning off all the goodies didn’t help. i still have the crashes.

    oh well i’m going to wait for the next release then.

    cya and thanks.

    #48797

    Pam
    Participant

    Add the following lines to Section Screen in your xorg.conf:

    Option “RenderAccel” “true”
    Option “AllowGLXWithComposite” “true”
    Option “AddARGBGLXVisuals” “True”

    GCC compiles with optimisation level 2 by default which gave me crashes.
    Try to run ./configure with this options:

    CXXFLAGS=”-O1 -fno-strict-aliasing”

    you might add -march=pentium4 or whatever CPU you’ve got.

    #48798

    kowal
    Participant

    thanks pam, i’ve followed your suggestion. now i’m testing it. gonna post back when i have results.

    update #1:
    nope, still got the crashes.
    i’ll try playing with no sound now. i hope this works.

    update #2:
    nope, no sound didn’t help. but i can play a bit longer with no sound selected.

    #48799

    parasti
    Participant

    Can you post a debugger back trace? Check out the Coredump wiki article for instructions.

Viewing 15 posts - 1 through 15 (of 31 total)

You must be logged in to reply to this topic.