This topic contains 11 replies, has 0 voices, and was last updated by  Panther30 11 years, 6 months ago.

  • Author
    Posts
  • #4432

    Panther30
    Participant

    I just saw scorched stop at a strange spot and throw up an error while I compiled an install of 39.1 from the source code.

    it stopped at GLWplanview.Tpo and threw up this error:

    then mv -f “.deps/GLWPlanView.Tpo” “.deps/GLWPlanView.Po”; else rm -f “.deps/GLWPlanView.Tpo”; exit 1; fi
    ../landscape/LandscapePoints.h:44: error: extra qualification ‘LandscapePoints::’ on member ‘findPoint’
    ../landscape/MovementMap.h:68: error: extra qualification ‘MovementMap::’ on member ‘POINT_TO_UINT’
    make[2]: *** [GLWPlanView.o] Error 1
    make[2]: Leaving directory `/home/server1/scorched/src/scorched’
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/server1/scorched/src’
    make: *** [all-recursive] Error 1

    strange place for it to stop. Any ideas why?

    —Panther

    #29541

    cbx550f
    Participant

    I’m guessing you’re running quite a new version of gcc…

    Try changing line 44 in landscape/LandscapePoints.cpp from:

    void LandscapePoints::findPoint(HeightMap &map, Position *pos, float x, float y);

    to

    void findPoint(HeightMap &map, Position *pos, float x, float y);

    cbx

    #29542

    Panther30
    Participant

    that did the trick cbx, thanks dude.

    I edited all three errors and got past GLWplanview.

    I’ll let you know if there are any other problems.

    #29543

    Panther30
    Participant

    okay I got a few warnings while compiling the source, but it compiled. Ater I installed it, I ran scorched3d and got this error

    X Error of failed request: BadWindow (invalid Window parameter)
    Major opcode of failed request: 4 (X_DestroyWindow)
    Resource id in failed request: 0x0
    Serial number of failed request: 1481
    Current serial number in output stream: 1487

    #29544

    Panther30
    Participant

    I just tried a cvs install for scorched and I got the landscape file errors again when I tried to compile. they were a little different this time and I didn’t make a copy of the error. I will try again later and post the error after that.

    I think for now since I don’t need stats, I’ll just install from the rpm.

    #29545

    Panther30
    Participant

    After five days and many attempts to patch, I am still getting the sane errors (see above)

    #29546

    Panther30
    Participant

    I just tried compiling the cvs version and got this error during make.

    then mv -f “.deps/Landscape.Tpo” “.deps/Landscape.Po”; else rm -f “.deps/Landscape.Tpo”; exit 1; fi
    make[2]: *** No rule to make target `../landscape/LandscapeDefinition.cpp’, needed by `LandscapeDefinition.o’. Stop.
    make[2]: *** Waiting for unfinished jobs….
    make[2]: Leaving directory `/home/server1/scorched/src/scorched’
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/server1/scorched/src’
    make: *** [all-recursive] Error 1

    I’ll try the patches and see if they do anything to fix this.

    oops the patches didn’t patch to the cvs version.

    #29547

    Panther30
    Participant

    okay going back to the tar.gz version of 39.1 I made the changes to landscapepoints.h and mvementmap.h as cbx decribed. Scorched compiled fine again. but…

    I sitll get the BadWindow error when I try to launch scorched.

    Sometimes scorched will refuse to run at all an I get a ‘could not find file or directory’.

    and I can start scorched in server mode with the -console -startserver switches.

    without using the -console switch scorched keeps telling me the Graphical SDL libraries are missing.

    and also when scorched does start up, stats do not record (all my stats files were pulled directly from a working server). this might be due to the new mysql 5.0.23, I really do not know.

    #29548

    Panther30
    Participant

    okay

    new problem:

    installed wxGTK 2.6.3 and now a couple things are happening to my modified (editiedfor the landscapepoints and movementmap errors I kept getting before) version of scorched (version 39.1)

    1. scorched will not find my freetype install so I had to use –disabled -freetypetest for it to even get past the first part of the build.

    2. Once it compiles, I run it and it says something about not being able to find wxgtk-2.6.so or something and scorched refuees to run.

    #29549

    Crispy Critter
    Participant

    Try putting the following at line 85 of the configure script:

    wx_config_args='--unicode=no'
    #29550

    Panther30
    Participant

    newest error (after installing wxGTK 2.6.3)

     error while loading shared libraries: libwx_gtk2_xrc-2.6.so.0: cannot open shared object file: No such file or directory
    #29551

    Crispy Critter
    Participant

    Hmm… are you using gcc 3.2 or 4.1?

    I compiled my 39.1 with gcc 3.2 because I didn’t know enough yet about how to get it to compile with 4.1.

    NOTE: You will need to install compat-wxGTK-devel as well. This brings in wxGTK 2.4.

    When you run your configure script, try:

    CC=gcc32 CXX=g++32 ./configure --disable-freetypetest

    and then try building it.

    …Oh, yes. One other thing. You’ll need to modify src/scorched/Makefile to bring in some libraries.

    The line beginning with LIBS (line 359 in my copy) should read:

    LIBS =  -L/usr/lib64 -lSDL -lpthread -lSDL_net -lGL -lGLU -lpthread -L/usr/lib64 -lopenal -lalut -lpango-1.0 -lpangox-1.0 -pthread -lwx_gtk2-2.4 -lfreetype -lz
    #29552

    Panther30
    Participant

    many thanks,

    I am about to switch my server from linux to winodws I am having some issues with some hardware (pci 4 port router) that cannot be solved in linux without a lot of work.

    I appreciate all the help I have gotten so far from you and everyone else on my issues with fedora core 5 and scorched.

    —Panther30

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.