This topic contains 1 reply, has 0 voices, and was last updated by  Bobirov 11 years, 3 months ago.

  • Author
    Posts
  • #4549

    Bobirov
    Participant

    Its probably less of a bug and more of a feature, but I’ve noticed that WeaponGiveAccessory is limited by the server’s current armslevel restriction. This leads to situations in the early rounds where you can collect cargo and see the “player received x number of y weapon” message, but you don’t actually receive the weapon.

    If possible, I would like it if the armslevel restriction was ignored alltogether when receiving weapons via WeaponGiveAccessory. As it stands right now, it can be very misleading and confusing when you see the ‘weapon received’ message, but then you can’t find the weapon in your inventory.

    #30751

    imported_gcamp
    Participant

    Tricky one, you are correct, each weapon given to a tank is verified against the current set of allowed weapons.

    I guess it could be possible to turn this off for weapons recieved this way.
    The other option is to disable the message I guess?

    #30752

    Bobirov
    Participant

    @gcamp wrote:

    I guess it could be possible to turn this off for weapons recieved this way.
    The other option is to disable the message I guess?

    I had thought about this as well. But my thinking was that this would cause just as much anger when a player spends 3 turns trying to shoot a cargo box only to find that he got nothing in return. 😛

    My other idea was that, if the weapon received was not yet available, you could retry the GiveCargo event a number of times to see if a weapon that was available could be given. This would work fine for the way I have things set up, but I could see that not working at all depending on how the server and powerup that is being tryed is set up. For instance if the powerup being shot only gave 1 type of item, no amount of retrying the Give event would yield a usable item. So I figured that probably wasn’t a viable option.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.