This topic contains 3 replies, has 0 voices, and was last updated by  imported_gcamp 13 years, 5 months ago.

  • Author
    Posts
  • #2654

    Anonymous
    Participant

    Hi everyone, here newbie on the forum.
    Before posting I searched on the forums and the website for info on my problem but couln’t find anything near my problem.
    Anyway, im trying to compile the source on a Suse 9.2 laptop with an nvidia geforce 4 420 and configure throws :

    checking for OpenGL support… no
    configure: error: *** Can’t find the OpenGL library Try: http://www.opengl.org

    my glxinfo shows:

    server glx version string: 1.3
    client glx version string: 1.3
    OpenGL version string: 1.4.1 NVIDIA 53.36
    glu version: 1.3

    the glx enviroment variables are set and I can also play ut2004 and other opengl games so I don’t know what could be the problem.
    I also tried to install the game through rpm but everytime I try to start a new game the program shows a window complaining about the lack of opengl extensions.

    I thought about posting my dmesg here but I really don’t know if its going to be useful. If anyone needs more information please ask.

    #11882

    imported_gcamp
    Participant

    The compiler looks for an include directory called GL perhaps your directory is called gl. If this is the case you can simlink one to the other.

    #11883

    Anonymous
    Participant

    strange I found the GL folder inside /usr/include/ then just in case I made simlinks from that folder into /usr/local/include. Still ./configure throws the same error. Im using a pretty much a default installation of SuSE 9.2 the only differences I’ve done to the system so far are just some eyecandies and libvdvcss .

    #11884

    wolface
    Participant

    ok, the last post was mine… now im registered :p

    #11885

    imported_gcamp
    Participant

    I can’t really think of any issues that could occur. When doing this check it tries to compile a program like this.


    #include
    #include


    int main()
    {
    return 0;
    }

    Perhaps you could trying putting this code into a file and compiling it. That should show you what the problem is.

    You could also use the –disable-opengltest flag to supress the error 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.