This topic contains 2 replies, has 0 voices, and was last updated by  Bobirov 13 years, 6 months ago.

  • Author
    Posts
  • #2609

    Bobirov
    Participant

    For some reason, no matter what I do, certain (custom?) landscapes are always disabled when I boot up my server (bullseye for instance). Even if I enable all the maps (using File-Edit Settings-Land) and save the settings again, the next time I boot the server with the settings the maps are disabled again.

    I used to be able to just get around this by using File-Edit Options… to re-enable the maps right after I boot up the server. However, ever since I started using a windows mysql compile, I have noticed that if I change the landscapes at all (through Edit Settings), the mysql stats logger is automatically disabled when the settings change. Unfortunately, I have found no way to re-enable the logger after the server has been launched. The only thing I could think of was to load a settings file that has the logger flagged to enable but that does not seem to work.

    And so here I am stuck, unable to run some of my custom maps without disabling the mysql stats logger (not an option ;)). Hopefully at least one of these two bugs can be found and squashed easily so I can get back to the business of killing on my favorite maps.. 😉

    Rob

    #11696

    imported_gcamp
    Participant

    For some reason, no matter what I do, certain (custom?) landscapes are always disabled when I boot up my server (bullseye for instance). Even if I enable all the maps (using File-Edit Settings-Land) and save the settings again, the next time I boot the server with the settings the maps are disabled again.

    I dont understand this. What is put in the xml file? When you do the save vs the name of the landscapes.

    I used to be able to just get around this by using File-Edit Options… to re-enable the maps right after I boot up the server. However, ever since I started using a windows mysql compile, I have noticed that if I change the landscapes at all (through Edit Settings), the mysql stats logger is automatically disabled when the settings change. Unfortunately, I have found no way to re-enable the logger after the server has been launched. The only thing I could think of was to load a settings file that has the logger flagged to enable but that does not seem to work.

    Although it says the stats logger has been disabled I’ll wager it has not 🙂
    I think it is actually the disabled message that is the bug and the stats logger is not disabled. Try connecting and see if you still get the stats message.

    #11697

    imported_gcamp
    Participant

    Oh yeah I forgot to say, if you put this into the server.xml file it should use all landscapes :-

    	

    #11698

    Bobirov
    Participant

    @gcamp wrote:

    I dont understand this. What is put in the xml file? When you do the save vs the name of the landscapes.

    Here is the actual line from my .xml file :



    The, “Bullseye” map here is always disabled when I start up the server tho, even though it is cleared listed in the landscapes list. What I used to do was re-enable the landscape, then add a few bots to make the map switch so the changes would take effect, then I would re-save the xml. I don’t know why that would not work.

    @gcamp wrote:

    Although it says the stats logger has been disabled I’ll wager it has not
    I think it is actually the disabled message that is the bug and the stats logger is not disabled. Try connecting and see if you still get the stats message.

    Ya know, if I had a brain I would have actually checked to see if the server was LYING to me or not. You seem to be correct sir. After reading this I tryed it. I enabled the map, got stats logger disabled messaged, checked rank and it is still working just fine I think. I haven’t yet done a dump since I tryed it but, it “should” be working. If I notice any further problem I’ll let ya know.

    Rob

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.