This topic contains 6 replies, has 0 voices, and was last updated by  Anonymous 13 years, 11 months ago.

  • Author
  • #2468


    We are pleased to announce the next version of Scorched 3D, build 37.

    Download right now from :-

    New main features include :-
    o Landscapes are very different between rounds
    o Trees and waves
    o Free market economy
    o New game GUI
    o Compatability fixes for radeon graphics cards
    o Compatability fixes for on board sound cards
    o Compatability fixes for intel graphics cards
    o Many more fixes and features, for the full list of changes see:-

    I would like to thank the following people who all contributed far too much time over the course of this project…

    Developers :-
    Gavin Camp
    Cameron Smith
    David Beleznay
    Ben Phipps
    Joris Beugnies
    C Thomas

    Contributions :-
    Danny Roth
    Bryan Kostanski
    Maxim Genis
    Edward Rudd
    Leszek Matok
    Dominik Czaplicki
    Tom at lemuria
    Per Øyvind Karlsen
    Darren Creutz



    I have a problem where the game is crashing at the end of each round. I am currently trying to determine which setting is causing the crash. If I disable all the troubleshooting settings, the game does not crash. I note that the game has crashed when the game disappears and an application (not windows) dialog box pops up stating that the game terminated unexpectedly. It does not specify an error. I can e-mail you a screenshot upon request. If this is not the proper place to post information like this, then please direct me to the correct location.

    I am running Win2k Server with all the latest service packs and patches on a Dual CPU 733 MHz system with 512MB RAM. My video card is a NVidia Riva TNT2 with 32MB RAM. Sound is a SoundMAX Integrated Digital Audio device. Running on a Dell Precision 220 Workstation. I’ve also tried disabling one of the CPUs. Thanks in advance!

    P.S. I love the new version. The landscaping and additional features are excellent!



    This may sound vain, but scorch only crashes if I win the round. After numerous trials, I got the game to crash with all the troubleshooting settings disabled. I need only win the round. Go figure. If a computer player wins or if nobody wins, the next round loads. So, I’m at a loss as to what I should do. The actual message reads as follows:

    “Scorched3D Abnormal Termination
    The Scorched3D process terminated unexpectedly.
    The error given was :-

    Would you like to load the failsafe scorched3d settings?
    This gives the best chance of working but at the cost of graphical detail.
    You can adjust this later in the Scorched3D display settings dialog.”



    FYI, I can reproduce this error 100% of the time if I start a game with LARGE texture sizes selected:

    “Microsoft Visual C++ Library
    Runtime Error!
    Program: D:Program FilesScorched3Dscorched.exe
    abnormal program termination”

    Followed by this error dialog:
    “Scorched3D – Version 37 (ah): scorched.exe – Application Error
    The instruction at “0x10015ad7” referenced memory at “0x0a82e940”. The memory could not be “read”.
    Click on OK to terminate the program”

    Each time the error occurs with the same instruction location and memory location. I hope this error reporting is helpful. Thanks again for your work on this awesome game!



    Thanks for the info. I will try and reproduce it. I just need to try and win a game :).



    Thank you for the next level of fun πŸ™‚

    The new version is great! I like how you implemented the ‘beam up’ effect after a tank kill (its amazing how you implement features of the original scorched earth version). => also ill try rollers πŸ˜†

    the great improvements in graphics made me 😯

    hopefully i will soon (again) rule the stats πŸ˜›




    Upgraded to nVidia’s latest release (4/1/2004) and that fixed my crashing problems. Now, the only remaining problem is that I cannot run with large texture sizes with GL extensions enabled. I have to run on medium texture sizes with GL extensions enabled, or can run on large texture sizes with GL extensions disabled. Otherwise, scorch crashes in a nasty way.

    I’m so happy to be able to play multiple rounds of the game now. The new graphics and special effects are awesome! Keep up the great work. Thank you.



    wow the graphics are so nice! Much more polished than previous versions.

Viewing 8 posts - 1 through 8 (of 8 total)

The forum ‘news’ is closed to new topics and replies.