This topic contains 5 replies, has 0 voices, and was last updated by  dracon23 13 years, 2 months ago.

  • Author
    Posts
  • #2745

    dracon23
    Participant

    Hey all,

    I am working on a tank and the model is now complete. I have also succeded in inserting the new tank into the game.

    What I can’t understand is that if tank skins are active in the game settings a game will start but at the tank selection window in attempting to select my new model the game crashes. All that i know is that it has something to do with the basic solid color skin that i am trying to use on it (since milkshape texture coordinater will not munction on my system). The skin is 128×128 solid green color in .bmp format (I already tried smaller and larger skin files but the same error’s occure).

    I get two error messages also:

    first

    failed to load texture file “./data/tanks/dragon/../../../../Progra”

    second

    texture
    209:scorcgedsrc3dsparseModel.cpp

    plus the usual safe settings message

    the model works if “no tank skins” in the settings is checked

    my tank is a dragon -> go figgure 😉
    if any one wants to see it i will post it

    Hope someone can help.

    dracon23

    #12418

    cbx550f
    Participant

    Did you verify the path is correct in your model’s file? Best to compare it with that of another.
    i.e., in the gorilla.txt: “.gorilla.bmp”

    #12419

    imported_gcamp
    Participant

    Edit the milkshape model file (its a text file) and make sure the texture paths in the file are correct. They should usually be ./ if the textures are in the same directory as the model file.

    #12420

    dracon23
    Participant

    thanks for your advice but it doesn’t quite work.

    here is what is in the file:

    “……..Program FilesScorched3Ddatatanksdragondragon.bmp”
    “”
    including quotemarks. the path is correct but i am not sure about the first couple of .. things. so i took them out.

    …..

    well that gives me an error that is the same except it says

    failed to load texture file “./data/tanks/dragon./Progra”

    instead of

    failed to load texture file “./data/tanks/dragon/../../../../Progra”

    sorry any more ideas?

    dracon23

    #12421

    dracon23
    Participant

    thanks for your advice but it doesn’t quite work.

    here is what is in the file:

    “……..Program FilesScorched3Ddatatanksdragondragon.bmp”
    “”
    including quotemarks. the path is correct but i am not sure about the first couple of .. things. so i took them out.

    …..

    well that gives me an error that is the same except it says

    failed to load texture file “./data/tanks/dragon./Progra”

    instead of

    failed to load texture file “./data/tanks/dragon/../../../../Progra”

    sorry any more ideas?

    dracon23

    #12422

    cbx550f
    Participant

    It sounds like it’s prepending the path, and you are also adding it, so I think just changing the path to:
    “.dragon.bmp”
    should fix it up.

    #12423

    dracon23
    Participant

    thanks that did the trick!

    as soon as i am able to get the texture coordinater on milk shape to work i will re skin my tank/dragon and post it for you all. 😀

    dracon23

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.