This topic contains 8 replies, has 0 voices, and was last updated by  imported_gcamp 11 years ago.

  • Author
    Posts
  • #4845

    Willis
    Participant

    Installing scorched under a distribution of Linux… Ubuntu (Debian). *WHICH I AM NOT EXPERIENCED IN!!!*

    But recently i’ve come across some .. confusion.. with the data layout.

    It’s possible that my installation is corrupted, but I cannot use the client-logging feature, Every time I attempt to APPLY changes, it reverts back to not being used.

    Is this expected?

    I also cannot locate the ids.xml file (or an equivlent). Even though the game knows and records ID information as though one exists. Under normal conditions where should it exist?

    I’ve also found that the screen displays apear “flawed”. It’s all block like, without smoothness. (YET… ubuntu repository has a v39 that I tried .. and the buttons and menus apeared perfectly).

    Again, 100% of this could be due to a faulty installation of the package, so if someone could help me try and locate the missing files…

    Better off, if someone could help explain how to fully remove, and properly install the application.. that would be great.

    #34001

    Christian.ger
    Participant

    I also cannot locate the ids.xml file (or an equivlent). Even though the game knows and records ID information as though one exists. Under normal conditions where should it exist?

    The “ids.xml” is usually located in the s3d configuration directory of the user who is running the game. Eg: My user name (in linux) is “chk”, my home directory is “/home/chk/”, so the file is “/home/chk/.scorched3d/ids.xml”.

    If the name of your user, who is running the game, is “willis”, the file should be “/home/willis/.scorched3d/ids.xml”. You have to know, that files and directories with a leading dot (like “.scorched3d”) are handled as hidden. Maybe you have to enable something like “show hidden files” in your graphical file browsing tool.

    #34002

    Irishbandit
    Participant

    @willis wrote:

    It’s possible that my installation is corrupted, but I cannot use the client-logging feature, Every time I attempt to APPLY changes, it reverts back to not being used.

    I have had that problem in both windows and ubuntu. To fix it edit your
    “/home/*user name*/.scorched3d/display.xml” file

    edit this part:

    ClientLogToFile
    on

    change the value to on. save the file.

    I am having some issues with the way fonts are being displayed but only in the scorched main window not in the game i will post a screen shot when i get home to show you what i mean.

    #34003

    Irishbandit
    Participant

    @willis wrote:

    I’ve also found that the screen displays apear “flawed”. It’s all block like, without smoothness. (YET… ubuntu repository has a v39 that I tried .. and the buttons and menus apeared perfectly).

    The box look has to do with the theme you have installed and that you are using, i think.

    #34004

    Willis
    Participant

    Here’s a bigger screenshot of the server-select window.

    THE SECOND attachment is from the Ubuntu Repository, of version 39.1

    Their displays correctly (more or less)… maybe they did something before sending to repository, maybe not?

    #34005

    Lithium
    Participant

    I use Kubuntu, which is the same as Ubuntu except my desktop suite is KDE and yours is Gnome. Anyway, I’ve only seen and run Scorched3d in Linux and I don’t know what all the Scorched3d files are for so my perspective on this may be a little strange…

    I found my ids.xml file in my /home//.scorched3d/ directory so that’s probably where yours should be.

    Your Server-Select window looks identical to mine. Isn’t that how it should look? I usually maximize the window and resize the column widths.

    I never paid much attention to the client logging feature. If the feature is supposed to save all your “talk” data to a file, then I guess I never bothered with it. One thing I noticed is the Next, Previous, and End Of Log buttons are just little buttons…You have to mouse over them to see the label. Is that how its supposed to be?

    If you want, you can install the Debian package that’s included on the Scorched3d website instead of converting the RPM to a deb package. The only reason I converted the RPM to DEB is because I was getting an error message on Scorched3d exit…For some reason, the converted DEB package solved that. See http://www.scorched3d.co.uk/phpBB2/viewtopic.php?t=3433&highlight=

    Here are some screenshots showing how my game looks:

    #34006

    Lithium
    Participant

    Okay, I think maybe I understand what your asking about, Willis. In a comparison between your screenshots of Version 39.1 and 40.0, Version 39.1 looks cleaner and refined, especially with the column headers. I’ll take a wild guess that maybe this had something to do with libqt (??) or other GUI dependancies that were used to compile Scorched3d before it was packaged.

    #34007

    imported_gcamp
    Participant

    Its probably to do with the options wx-windows was compiled with/against. If you do an ldd on both what graphics libraries are they using?

    #34008

    Lithium
    Participant

    @gcamp wrote:

    Its probably to do with the options wx-windows was compiled with/against. If you do an ldd on both what graphics libraries are they using?

    linux-gate.so.1 => (0xffffe000)
    libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xb7e83000)
    libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7e61000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0xb7ddb000)
    libGLU.so.1 => /usr/lib/libGLU.so.1 (0xb7d65000)
    libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0xb7c2a000)
    libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0xb7bf4000)
    libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0xb7bf1000)
    libgthread-1.2.so.0 => /usr/lib/libgthread-1.2.so.0 (0xb7bee000)
    libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0xb7bc9000)
    libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7bc6000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xb7bbe000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xb7bb1000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xb7acb000)
    libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7aa9000)
    libogg.so.0 => /usr/lib/libogg.so.0 (0xb7aa3000)
    libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb7a7b000)
    libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3 (0xb7a73000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7a0a000)
    libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7950000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7946000)
    libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7816000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0xb7761000)
    /lib/ld-linux.so.2 (0xb7f0e000)
    libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0xb6f9f000)
    libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0xb6f9d000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6ec8000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xb6ec4000)
    libz.so.1 => /usr/lib/libz.so.1 (0xb6eb0000)

    #34009

    imported_gcamp
    Participant

    Yeah looks like GTK 1.0 is being used. I am asuming you would see something like libgtk-x11-2.0.so.0 if GTK 2.0 was being used. This should be a configuration option for wxWindows.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.