This topic contains 3 replies, has 0 voices, and was last updated by  Deathstryker 9 years, 11 months ago.

  • Author
    Posts
  • #6028

    parasti
    Participant

    I’ve only tested this on Main, using a self-compiled v41.1 on Debian Lenny. When joining the server, the initial MOTD is shown correctly, however, on any further requests (such as pressing the “r” key or after loading a map) only the first line of the MOTD is shown. Seems like a bug with handling newlines.

    I would have posted some screen-shots, but I didn’t manage to take a screen-shot of the initial MOTD. Is the keyboard somehow handled differently there?

    #46504

    BOY
    Participant

    I think i have encountered this, but i could be the inability of the MOTD display to account for line “returns”

    make sure that you enter all info in MOTD line by line so that the length of each line fits the display.

    I could be wrong though, not tested this out for the new version just yet.

    #46505

    Thrax
    Participant

    @boy wrote:

    I think i have encountered this, but i could be the inability
    of the MOTD display to account for line “returns”

    make sure that you enter all info in MOTD line by line so that the length
    of each line fits the display.

    I could be wrong though, not tested this out for the new version just yet.

    There is a flaw.

    Scorched3D : Copyright 2004 Gavin Camp( & # 10 ;)For updates and news visit: (& # 10 ;)http://www.scorched3d.co.uk

    vs

    Scorched3D : Copyright 2004 Gavin Camp
    For updates and news visit:
    http://www.scorched3d.co.uk

    the former instructs it to line-break, the latter assumes.
    currently, the latter is no longer working propperly.

    #46506

    Rommel
    Participant

    I thought this had already been reported but since I was wrong, then I’ll mention or re-mention this one as well. The rules don’t update properly either. When gravity is set to something other than -10 and you check the rules, you still see the gravity listed as -10.

    @parasti wrote:

    I’ve only tested this on Main, using a self-compiled v41.1 on Debian Lenny. When joining the server, the initial MOTD is shown correctly, however, on any further requests (such as pressing the “r” key or after loading a map) only the first line of the MOTD is shown. Seems like a bug with handling newlines.

    I would have posted some screen-shots, but I didn’t manage to take a screen-shot of the initial MOTD. Is the keyboard somehow handled differently there?

    #46507

    Deathstryker
    Participant

    I think I remember it being reported too.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.