This topic contains 20 replies, has 0 voices, and was last updated by  Irishbandit 8 years, 11 months ago.

  • Author
    Posts
  • #54149

    naka
    Participant

    ATI?
    but i believe it is possible creating such modes. thats a very tricky procedure. Needs a lot tries and mistakes by slightly changing the numbers.

    Other think i have noticed: Event the mode line is correct, starting X depends of the lines
    HorizSync,VertRefresh in “Monitor” section.

    Section “Monitor”
    HorizSync 31.0 – 65.0
    VertRefresh 20.0 – 65.0
    EndSection

    a fictional example: it won’t start whit HorizSync 31.0 – 65.0; but will start whit 31.0 – 68.0; and again it won’t start at 31.0 – 70.0; and so on?
    even mode line is correct, and it falls into the valid HorizSync,VertRefresh band, some times X refuse to start.

    pizza start linux in Runlevel 3, then open 2 terminals.
    into to the first open xorg.conf for editing, and make changes. (no need to close editor)
    into the second type X, every time you made changes into the first terminal. you can kill X anytime by ctrl+alt+backspace. Needs a lot tries and mistakes.

    #54150

    Laptops Daddy
    Participant

    no. dude! nak! too old-school! anyone new to linux is gonna run a mile. vi!

    ok – heres my suggestion (humble one. linux noob etc)

    edit your xorg.conf within your desktop environment (ie in a modern 21st century style text editor). you can gain root access to the file by running your file manager as super user. (eg: sudo nautilus). add several modelines to your monitor section if you need to, then restart x. you should then be able to test your new modes within x, using the gui to change res, taking advantage of the ‘do you want to keep this setting’ feature.

    ps:
    i think refresh rate settings are part of the modeline.

    @naka wrote:

    …into the second type X, every time you made changes into the first terminal. you can kill X anytime by ctrl+alt+backspace. Needs a lot tries and mistakes.

    #54151

    xtc
    Participant

    I did what you suggested with the first try. I started with changing HorizSync which was 30-62 and I made it 30-65. Next time system started with my custom modeline absolutely like usual. However, it couldn’t be found anywhere in the graphics settings utility mode selector to try it. (and scorched would simply run in 1024×768 with 960×600 rectangle of used area)
    Moreover, I even tried completely removing all “1280×800” from xorg.conf leaving only “960×600” and setting it as a PreferredMode. But still system would start up 1280×800 as if it changes nothing at all (even if 960×600 was a failure, how could it know about 1280×800 if it isn’t even mentioned??).

    I also tried changing resolutions from available just to see how it affects xorg.conf. For example, if I selected 1024×768 it would be put as preferred mode, my modeline erased, and in screen section resolutions were “1024×768” “800×600” “640×480”. I failed to see interconnection of this and modes selector…

    So I’m not able to say whether it works or not at all, I guess there must be something peculiar for opensuse to be modified as well. I posted this problem at the opensuse forums, maybe I get some advice there.

    #54152

    parasti
    Participant

    @laptops Daddy wrote:

    you can gain root access to the file by running your file manager as super user. (eg: sudo nautilus).

    Well, why don’t you just delete your user profile and log in as root from then on… Less hassle for everyone, right? 😉 (To anyone thinking this sounds like a good idea: I’m being sarcastic, don’t ever attempt a stunt like that. The less software you run as root, the better. This especially applies to bug-ridden bloated graphical software.)

    Seriously though, GNOME has a neat “graphical su” utility called “gksu” (which is maybe available somewhere in the GNOME menu labyrinth under a descriptive name such as “run as”). You can use this to run “gedit” (i.e., a “modern 21st century style text editor” or, in other words, “notepad with some bells and whistles”), and then open your system configuration files directly from the editor.

    You’d do yourself a favour by learning to use a “text mode” editor, though. No matter if it’s vi, emacs, or whatever. It’ll pay off the moment you find yourself with a crashed/non-starting X and a black screen with a blinking cursor at the bottom.

    #54153

    xtc
    Participant

    I have no troubles with command line, its pretty much like DOS and I loved DOS! 😀

    I personally don’t get why the hell we should use all those heavy systems, all they needed was to make DOS 32/64 bit and create a multi-task support better then interrupts system. Heh if someone told me like 15 years ago I’ll have computer with over 2GHz speed and 4Gb of memory I’d thought its something starting instantly and working with the speed of light… nahhhhhh… I swear my 486SLC2 was starting three times quicker then this linux (even though 1/3 of that time was taken by the test of ‘poor’ 3Mb extended memory), I don’t even want to think about vista. But I have “friendly user interface” which is driving me crazy because I have to learn complex guides and perform tricky actions to get deep into system just to get rid of some of its friendliness that cant let me just work!

    I’m with kde and there is “kwrite” notepad for me that I can use for anything after typing su –
    I’m dreaming of times when I won’t have to…

    #54154

    Laptops Daddy
    Participant

    @xtc wrote:

    I personally don’t get why the hell we should use all those heavy systems…

    good points.

    i still use windows xp for anything important.

    top tip: s3 standby mode

    #54155

    Irishbandit
    Participant

    First off not to start a editor war. hehehe. But I prefer mousepad over gedit and as far as using the cli the first thing I install is MC short for midnight commander. If you where at home with dos edit, norton commander or dosshell then you will feel right at home.

    But always keep a cheat sheet around for vi.

Viewing 7 posts - 16 through 22 (of 22 total)

You must be logged in to reply to this topic.