This topic contains 3 replies, has 0 voices, and was last updated by  imported_gcamp 6 years, 9 months ago.

  • Author
    Posts
  • #7389

    kmoney
    Participant

    i looked for a thread of this nature but couldn’t find one.

    I download the following file:
    Scorched3D-43.1c-intel.dmg

    for my Mac os 10.4.11

    2.2 Ghz Intel Core 2 Duo

    When I goto the scorched bin folder and click on scorched3d. It acts as if it just opens and closes very quickly and nothing happens.

    any advice?

    bests,
    k

    #62063

    imported_gcamp
    Participant

    I’m not 100% sure but it may still require an x server to run, alternatively it could be requiring some libraries that aren’t on your pc.

    If you are familiar with how to bring up a command shell, running otool -L on the scorched binary should say what’s wrong.

    #62064

    Jerms
    Participant

    @kmoney wrote:

    When I goto the scorched bin folder and click on scorched3d. It acts as if it just opens and closes very quickly and nothing happens.

    any advice?

    I had a similar problem with Scorched 3D 43.2a (the latest version as of this reply). When I ran the program, the terminal displayed the following error:

    dyld: Library not loaded: /usr/lib/libwx_macud-2.8.0.dylib
    Referenced from: /Volumes/Scorched3D-43.2a-intel/bin/scorched3d
    Reason: image not found
    Trace/BPT trap
    logout

    @gcamp wrote:

    If you are familiar with how to bring up a command shell, running otool -L on the scorched binary should say what’s wrong.

    Here’s what I got:

    scorched3d:
    /usr/lib/libmx.A.dylib (compatibility version 1.0.0, current version 292.4.0)
    /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime (compatibility version 1.0.0, current version 1674.0.0)
    /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
    /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 136.0.0)
    /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 12.0.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.5)
    /usr/lib/libwx_macud-2.8.0.dylib (compatibility version 2.6.0, current version 2.8.4)
    /usr/X11/lib/libfreetype.6.dylib (compatibility version 10.0.0, current version 10.20.0)
    /opt/local/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)
    @executable_path/../Frameworks/SDL.framework/Versions/A/SDL (compatibility version 1.0.0, current version 1.0.0)
    @executable_path/../Frameworks/SDL_net.framework/Versions/A/SDL_net (compatibility version 1.0.0, current version 1.0.0)
    @executable_path/../Frameworks/UnixImageIO.framework/Versions/B/UnixImageIO (compatibility version 1.0.0, current version 1.0.32)
    /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
    /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
    /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 227.0.0)
    /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 476.19.0)
    /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 949.54.0)
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 34.0.0)
    /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 677.26.0)

    I’m not exactly sure how to read the otool output, but as far as I can tell the problem is with the version of libwx_macud included with MacOS 10.4.11. The only *.dylib files in /usr/lib/ on my computer are libwx_macud-2.5.3.0.0.dylib, libwx_macud-2.5.3.dylib, and libwx_macud-2.5.dylib, so apparently the version 43 binary wants a newer version of the library than is available on MacOS 10.4.

    It may be possible to get the newest version to run on 10.4 by compiling from source, but I haven’t tried yet. Version 41.3 works fine for local play; I haven’t tried any versions newer than that except 43.2a.

    #62065

    fab4
    Participant

    Considering Apple dropped support for OSX 10.4 awhile back, why don’t you spend $29 and upgrade to Snow Leopard?

    #62066

    imported_gcamp
    Participant

    /usr/lib/libwx_macud-2.8.0.dylib (compatibility version 2.6.0, current version 2.8.4)

    This output should mean that its found a compatible version I think. Looking for version 2.6.0 found version 2.8.4. What happens when you do ./scorched3c from the same place?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.