This topic contains 88 replies, has 0 voices, and was last updated by  dipalina 7 years, 10 months ago.

  • Author
    Posts
  • #9599

    Anonymous
    Participant

    This will only be useful to those who have the latest fink and a working X11 server.

    I’ll host it here until it’s hosted officially at the scorched3d website.

    http://comp.uark.edu/~cjt01/scorched3d-OSX.tar

    c. thomas

    #9600

    imported_gcamp
    Participant

    Great work. thanks :).

    I have seen the link you gave for the patch in the other news item. I will download the patch etc and upload to the main site, if that is ok.

    #9601

    GoochRules
    Participant

    I’ve downloaded the port, but am still having issues.

    The first, just a FYI: I noticed that the wxgtk libraries mentioned in the INSTALL file require one to have the unstable fink branch enabled… this was not clear in any docs I read.

    After enabling the unstable brach in fink, I decided to install the various fink verions of libraries rather than cvs/source versions; in particular, the SDL_net library. When i attempted to ./scorched3d from xterm, I got errors about /usr/local/lib/SDL_net-1.2.0.dylib not existing. So I “ln -s /sw/lib/SDL_net-1.2.0.dylib /usr/local/lib/SDL_net-1.2.0.dylib” to resolve that problem.

    Now, I am getting errors about the data directory:

    [goose@Trogdor] /Games/Scorched3D-36.1/scorched3d> ./scorched3d
    Scorched3D – Version 36.1 (ae) : Warning: This game requires the Scorched3D data directory to run.
    Your machine does not appear to have the Scorched3D data directory in
    the same directory as the scorched.exe file.

    If Scorched3D does not run please re-install Scorched3D.

    Notice, I am not running the game from /usr/local/games as specified in INSTRUCTIONS.

    #9602

    Anonymous
    Participant

    I’d suggest you put the scorched directory into /usr/local/games as the INSTRUCTIONS file said… You’ve obviously read that part, didn’t you try it?

    You’re right, the unstable branch of fink needs to utilized in order to get all the libraries – also they need to be compiled by ‘fink install’ – the precompiled binaries don’t include the development files you need.

    c. thomas

    #9603

    GoochRules
    Participant

    I’d suggest you put the scorched directory into /usr/local/games as the INSTRUCTIONS file said… You’ve obviously read that part, didn’t you try it?

    uh, yeah, my bad. sorry.

    So, its running now, it looks like crap, but its running. I have a 17″ powerbook with a nVidia GeForce4 MX 64 MB. The landscape looks just fine until I press the ‘ok’ button on the initial dialog. Then, depending on the video settings, a number of problems happen.

    The default seems to not clear the screen buffer before adding in the new polygons/textures. So I enabled ‘Full Clear’. That helped, but not very much, so I played around with the settings some. I currently have ‘Full Clear’, ‘No Multi Texture’, and ‘Don’t use TexSubImaging’ enabled. This seems to produce the ‘cleanest’ display, but it’s too clean, that is, there are clearly numerous polygons/textures missing from the landscape. No other options seem to help.

    Despite all this, the tanks/weapons/explosions do look great.

    #9604

    Anonymous
    Participant

    I’m working on a second revision of my patched binary.
    I should have the backspace key working (a small fix, once I found the code responsible), and will make sure that the correct libSDL-net is linked in (I had two versions, and for some reason the /usr/local/lib version linked; that’s fixed now).

    I’ll also update the INSTRUCTIONS file with your observations about fink.

    I’m using a TiBook 1ghz, with a Radeon 9000 64MB. The graphics are peachy keen with mine, and I suspect your troubles might be nvidia’s GL implementation, although don’t quote me on that.

    If anyone else tries it, please post your experiences along with your hardware platform.

    Thank you Gooch, for your comments and for being the first tester of the port. Hope to see you online? My nick is Chomsky[OSX]

    c. thomas

    @goochrules! wrote:

    So, its running now, it looks like crap, but its running. I have a 17″ powerbook with a nVidia GeForce4 MX 64 MB. The landscape looks just fine until I press the ‘ok’ button on the initial dialog. Then, depending on the video settings, a number of problems happen.

    The default seems to not clear the screen buffer before adding in the new polygons/textures. So I enabled ‘Full Clear’. That helped, but not very much, so I played around with the settings some. I currently have ‘Full Clear’, ‘No Multi Texture’, and ‘Don’t use TexSubImaging’ enabled. This seems to produce the ‘cleanest’ display, but it’s too clean, that is, there are clearly numerous polygons/textures missing from the landscape. No other options seem to help.

    Despite all this, the tanks/weapons/explosions do look great.

    #9605

    GoochRules
    Participant

    Here’s some screen shots of my problems (these were taken in windowed mode, full-screen mode was giving crappy screen grabs… my fps is typically about 60). The first is hopeful. I can rotate, zoom, pan, etc., and it all looks good – the sky, water, land all are good. The second is what I get after clicking ‘ok’. As you can see, it appears the land is missing. The third is what I get after rotating, panning or zooming. Again, the land is missing, and it looks like the existing land is not being properly clipped. If I enable the ‘clear’-whatever check box, it looks a little better, but land is still missing. Through all this, sky, water, tanks, projectiles, and explosions all look good.

    I’m on a Rev1 1Ghz Powerbook, Mac OS X 10.3.2, fink 0.6.2.cvs/0.17.1. I just rebuilt sdl and wxgtk. I don’t think its a problem with the display drivers. I’d be much more inclined to blame it on wxgtk, sdl or scorch3d, because it looks right to begin with.

    I think the windowed mouse problems are that the y-axis is flipped, e.g. clicking in the top of a dialog box presses the button at the bottom of the box.

    #9606

    imported_gcamp
    Participant

    Try turning off tank skins in the scorched3d display dialog.

    #9607

    GoochRules
    Participant

    Tried it. Still same results. The game is playable, but large sections of the landscape are transparent.

    I have a lot more (very large) screen shots if any one is interested. I don’t have anywhere I can host them to be able to post them here.

    #9608

    GoochRules
    Participant

    I thought I had tried this option, but I guess not, because turning on ‘No GL Extensions’ in the display settings totally cleans up everything.

    So, this leads to two questions:
    1) what do these extensions do?
    2) why would they be causeing problems/how do i fix it?

    #9609

    imported_gcamp
    Participant

    Its strange though that is only doing it when the tank dialog comes up. It is like it is running out of polygons or display space or something. What happens if you edit the tank.xml file and take out most of the tanks.

    #9610

    Anonymous
    Participant

    A new panther update, 10.3.2, was made available yesterday, which includes display driver updates for nvidia and ATI chips. You might want to install it and see if it cleans up anything…

    Also, I still suspect that nvidia’s implementation of GL is hosed somehow, perhaps just the GL extension part.

    #9611

    GoochRules
    Participant

    A new panther update, 10.3.2, was made available yesterday, which includes display driver updates for nvidia and ATI chips. You might want to install it and see if it cleans up anything…

    Already did that, as I mention in the post with the screen shots.

    Also, I still suspect that nvidia’s implementation of GL is hosed somehow, perhaps just the GL extension part.

    I don’t think its a good strategy to start blaming vendors of implementation defects, without evidence of known issues. I seem to be the only one having these graphic problems, it is much more likely there is something unique about my software enviroment that is the cause, such the SDL library, the wxgtk library, the X11 enviroment, etc. Which is why i continue to ask for suggestions for tweaking settings, checking versions, etc.

    #9612

    Anonymous
    Participant

    Its strange though that is only doing it when the tank dialog comes up. It is like it is running out of polygons or display space or something. What happens if you edit the tank.xml file and take out most of the tanks.

    No difference (i didn’t even see a different selection of tanks to choose from, yes, I made sure the file was saved) — I commented everything but ‘Cammo Turret’, which I thought to be the least complex object. I didn’t think there would be… the display issues appear after i click the initial ‘OK’ button, and do not go away. My best guess is that something that happens after clicking that button corrupts (i.e. deletes) the landscape textures. Since this is a PPC port, I’d make sure that nowhere does the code depend on big/little endian-ness.

    Two other bugs:

    I don’t think swap up/down is working properly. During the second round of a game, I lost the ability to raise my turret with ‘Invert Up/Down’ in the display dialog selected.

    In the display properties, the resolution select box displays the correct resolution, but does not highlight it when the window is open; it defaults to 1440×900 initially. Once I select something else the something else is highlighted properly. But if i quit and restart the problem appears again. So, it was set to 1440×900 to begin with, i played a windowed game at 640×480, decided i liked full screen better, quit, restarted, the select box displayed 640×480, but when i clicked the arrow to open the box 1440×900 was highlighted (disallowing me to select it). So i choose something else (which becomes selected & highlighted), and then choose 1440×900.

    #9613

    Anonymous
    Participant

    @anonymous wrote:

    Its strange though that is only doing it when the tank dialog comes up. It is like it is running out of polygons or display space or something. What happens if you edit the tank.xml file and take out most of the tanks.

    No difference (i didn’t even see a different selection of tanks to choose from, yes, I made sure the file was saved) — I commented everything but ‘Cammo Turret’, which I thought to be the least complex object. I didn’t think there would be… the display issues appear after i click the initial ‘OK’ button, and do not go away. My best guess is that something that happens after clicking that button corrupts (i.e. deletes) the landscape textures. Since this is a PPC port, I’d make sure that nowhere does the code depend on big/little endian-ness.

    If this bug was because of endian-specific code, then I would also have this problem.

    I suggest in your case, that you compile with the GL headers that come with your system; perhaps they are slightly different (the implementation of GL extensions) from mine, which uses the ATI GL implementation.

    I can post a patch to the current source release which gives my current OSX branch – compile from that and let’s see if it solves some problems. At any rate, I think my patch should be merged upstream by the next minor release.

    Also, I’ve fixed the dependency on /usr/local/lib/libGL_net (should be /sw/lib) and now the backspace key works in the game… 😉

    -c. thomas

Viewing 15 posts - 16 through 30 (of 90 total)

The forum ‘news’ is closed to new topics and replies.