This topic contains 17 replies, has 0 voices, and was last updated by  jspoon 13 years, 10 months ago.

  • Author
    Posts
  • #2444

    Anonymous
    Participant

    i have sc3d and x11 for my mac g4 and the program won’t load past the screen where i select at which level of difficulty to play. please write back and tell me what i’m doing wrong.

    Can you run in from a command window and tell me what it says when it quits.

    how do i run it using a command line?

    #10849

    Chomsky
    Participant

    Please write back detailing your the complete hardware configuration (especially video) on your computer as well as the OS version number.

    btw, you can run scorched3d from a window by typing

    /usr/local/games/scorched3d/scorched3d

    into the application called xterm which is run by the X11 program.

    Good luck, and welcome to the world of unix.

    [/code]

    #10850

    jspoon
    Participant

    I just downloaded scorched3d for OSX today and have the same problem. Launching from xterm, I get the game selection windows, then it exits to the following error:

    morgan:/usr/local/games/scorched3d eliterrell$ /usr/local/games/scorched3d/scorched3d
    Display : ERROR: Failed to set video mode.
    Error Message: No video mode large enough for 1280×854


    Requested Display Mode:-
    Driver=Quartz
    Resolution=1280x854x0 (fullscreen)
    DepthBuffer=24
    DoubleBuffer=On
    ColorComponentSize=0

    Scorched 3D Display : ERROR: Failed to set the display mode.
    Ensure that no other application is exclusively using the graphics hardware.
    Ensure that the current desktop mode has at least 24 bits colour depth.

    Next time I launched, I went into the display options and clicked on the box for fullscreen display to uncheck it(curse your Unix check boxes) and now the game launches fine but the graphics are messed up, lots of stripiness, overlapping and bleeding. It’s late now, tomorrow I’ll try messing with the other graphics options to see if I can fix the problems.

    So, James, see if changing to windowed mode from fullscreen solves your crash problem. And Chompsky, et al, if you can jump in with a solution to either of the problems(I’d like to get it working fullscreen), that would be appreciated.

    I have a Quicksilver Powermac 733 Mhz G4, 640 MB ram with a geForce 4 Ti running MacOS X 10.3.2

    #10851

    jspoon
    Participant

    Ok, I figured out the fullscreen problem. I reread the error message and noticed as I should have noticed before that it said it was trying to go at a resolution of 1280×854 which my monitor doesn’t do. I went to display options and saw 1024×768 was the highest resolution on the pop up and that should work. I therefore tried changing it to 800×600 and back to 1024×768. This worked-now it operates full screen at my highest resolution. Still messed up though, I’ll get back to you if I figure out anything about the graphics problems.

    #10852

    Chomsky
    Participant

    @jspoon wrote:

    Ok, I figured out the fullscreen problem. I reread the error message and noticed as I should have noticed before that it said it was trying to go at a resolution of 1280×854 which my monitor doesn’t do. I went to display options and saw 1024×768 was the highest resolution on the pop up and that should work. I therefore tried changing it to 800×600 and back to 1024×768. This worked-now it operates full screen at my highest resolution. Still messed up though, I’ll get back to you if I figure out anything about the graphics problems.

    Start off by disabling all of the ‘bells and whistles’ and setting it to the lowest detail settings you can get, for all kinds of textures. Disable OpenGL extensions and any other things you can.

    This usually gets rid of most problems.

    After you’ve gotten your screen to look nicer, you can start re-enabling things one by one to see how far you can go without the problems coming back.

    Future OSX installation packages for scorched3d will include as defaults very very low system requirement settings, and then people can experiment with fancy stuff by themselves.

    Hope this helps…

    C. Thomas

    #10853

    jspoon
    Participant

    @chomsky wrote:

    Start off by disabling all of the ‘bells and whistles’ and setting it to the lowest detail settings you can get, for all kinds of textures. Disable OpenGL extensions and any other things you can.

    Thanks, I tried this. I turned everything off or down and it worked just fine. Then I went back and turned all the options back one row at a time and it still worked. Huh? I can think of two possibilities:

    1. First I thought maybe I got confused and clicked a check box more or less times than I thought I did. This would be easy because, as I said before, I have trouble with these silly check boxes.

    2. Then I thought back to my initial problem with the resolution. In that problem, the graphics were set by default to 1280×854 even though that wasn’t an option on the list. Maybe one of those other settings was set by default to something that is represented by neither a checked box nor an unchecked one. Just a possibility.

    Anyway, it’s a great game and I’m glad I got it working. When I get home tonight I’ll get X11 on my powerbook and install it on that too. Should be good fun.

    Thanks again for the help.

    #10854

    Chomsky
    Participant

    Gavin,

    This sounds kind of interesting… he’s reporting that the artifacts went away when he unchecked everything and then went back and rechecked it all….

    Could you theorize as to what could cause this behavior?

    @jspoon wrote:

    Thanks, I tried this. I turned everything off or down and it worked just fine. Then I went back and turned all the options back one row at a time and it still worked. Huh? I can think of two possibilities:

    1. First I thought maybe I got confused and clicked a check box more or less times than I thought I did. This would be easy because, as I said before, I have trouble with these silly check boxes.

    2. Then I thought back to my initial problem with the resolution. In that problem, the graphics were set by default to 1280×854 even though that wasn’t an option on the list. Maybe one of those other settings was set by default to something that is represented by neither a checked box nor an unchecked one. Just a possibility.

    Anyway, it’s a great game and I’m glad I got it working. When I get home tonight I’ll get X11 on my powerbook and install it on that too. Should be good fun.

    Thanks again for the help.

    #10855

    jspoon
    Participant

    New development: I installed Scorched3d on my Powerbook this morning. This time I decided to watch more carefully. It had the same crash on start-up problem and i verified that the display.xml file comes with a screen width of 1280 and width 854. Getting the resolution set to 1024×786, the game loaded to basically the same graphics glitches I got on my tower. Then, changing one option at a time, I set all the options on my Powerbook the way I have them on my other machine. The glitches didn’t go away. That would seem to support theory 2, that some option is initially set oddly, but then I ran the display.xml files through FileMerge. FileMerge came up with just one difference between them, the unique user ID number.

    Yet the video glitch persists. So I’m kind of puzzled. Is there anywhere else Scorched3d stores video preferences? Display.xml is the only thing that seems to be changing. Of course, I still need to confirm that it is at all possible to remove the glitches from the Powerbook, but that will take time because I’ll be going through the options in order.

    #10856

    imported_gcamp
    Participant

    Thanks for the systematic approach.

    You are correct, all the display settings are stored in the one file (display.xml). I can’t really think why it would help to check and uncheck the boxes.

    Have you tried rebooting the original box to see if the errors come back?

    #10857

    jspoon
    Participant

    @gcamp wrote:

    I can’t really think why it would help to check and uncheck the boxes.

    My thinking was along these lines: Perhaps checking a box sets the element to 0 and unchecking it sets it to one. But for some reason the preference file comes with it set to 2 or -1, maybe debugger mode or an experimental video mode which happens to cause problems on my machine. Thus, if I turn the feature off the problem will go away and if I turn it on again the feature works and the problem is still gone.

    This popped into my head because of the problem I had at first because the resolution in the pref file wasn’t on the list of options, making me think it was set to something my display could do. Anyway, I was totally wrong.

    Firstly, my laptop’s problem was totally unrelated. Just the matter of checking off one of the trouble shooting boxes- uncheck the box and it comes back, no voodoo.

    So I took the default display.xml file I backed up before playing around on the PowerBook and dropped it in my desktop’s data folder. The first thing I noticed when I brought up the display again was that the boxes ‘Don’t animate sky’ and ‘Don’t use texture details’ come pre-activated. Sure enough, unchecking the texture details box kills the problems, checking it brings it back.

    So what happened was this:
    -I turned everything off in the details section, problem persists.
    -I turned everything back on in the details section, off in the troubleshooting section, problem goes away. I think I’m onto something, assuming turning something off fixed the problem.
    -I turn troubleshooting features back on a few at a time, confidence turns to bewilderment when I’ve turned every single thing back on without the problem returning.
    -I run to the boards like a chicken with its head cut off then spend several hours painstakingly trying to recreate the event before finally figuring it out.

    Happy ending though. Good game. I’m very glad for the installer. I tried downloading it in December but hit a wall trying to get Fink to install the SDL networking library or something like that.

    Thanks for all the hard work.

    #10858

    Chomsky
    Participant

    Hi,

    I read your post, but I’m still unclear on why this preferences ‘magic’ was happening.

    Did you reach a verdict, or is the jury still out?

    Very happy that you found the installer useful 🙂

    c. thomas

    #10859

    jspoon
    Participant

    @chomsky wrote:

    Did you reach a verdict, or is the jury still out?

    Yes, er, sorry it got lost in there. I did reach a verdict.

    It was the box marked ‘don’t use texture details.’ It came prechecked. When I was unchecking things, I unchecked this too, then got confused because I assumed the problem would be solved by turning something off, not turning it on.

    #10860

    Chomsky
    Participant

    Gavin,

    This is a really minor point, but it seems odd that the error message only goes to stdout when the display resolution cannot be used.

    Your dialogMessage() function seems to have the capability of creating a wxgtk popup window. Perhaps this is yet another wxgtk inadequacy on OSX?

    #10861

    Chomsky
    Participant

    @jspoon wrote:

    @chomsky wrote:

    Did you reach a verdict, or is the jury still out?

    Yes, er, sorry it got lost in there. I did reach a verdict.

    It was the box marked ‘don’t use texture details.’ It came prechecked. When I was unchecking things, I unchecked this too, then got confused because I assumed the problem would be solved by turning something off, not turning it on.

    And this was on the machine with a geforce 4 mx, correct? Not the powerbook? (which vid card does your PB use, BTW?)

    #10862

    jspoon
    Participant

    @chomsky wrote:

    And this was on the machine with a geforce 4 mx, correct? Not the powerbook? (which vid card does your PB use, BTW?)

    It has a Ti. The tower is 733 Mhz, 640 MB Ram, GeForce 4Ti(128MB) and to work it needs the “Don’t use detail textures” NOT checked.

    The laptop is a 867 Mhz 12 inch Powerbook. It also has 640 MB of Ram, and has a Geforce 420 Go which shows as a GeForce 4MX in profilers and stuff so I assume it uses the same drivers as a standard MX. On the laptop, I need the “No compiled arrays” box marked for it to work. Nothing else seems to make a difference.

    Oh, and the tower is running OSX 10.3.2 but I reinstalled Panther on the PowerBook a few weeks ago and haven’t upgraded it yet so it’s just at 10.3 still. I’ll be doing that in a few days and I can let you know if it makes a difference if you like.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.