This topic contains 21 replies, has 0 voices, and was last updated by  Rommel 7 years, 9 months ago.

  • Author
    Posts
  • #7023

    gottyfunk
    Participant

    Hi,
    Just downloaded the program for Mac.
    Everytime I try to run it it crashes during the loading phase.
    Please help, I want to play!!
    Thanks,
    Daniel
    djg0825@gmail.com

    #57680

    fab4
    Participant

    Click on Settings-Safe Options and set the screen resolution to 640 x 480

    If that doesn’t work, please post your computer info and the version of OSX you’re running.

    #57681

    gottyfunk
    Participant

    Hi,
    I tried that but still crashes after trying to load landscape maps.
    System Info:
    Hardware Overview:

    Model Name: MacBook
    Model Identifier: MacBook4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 2 GB
    Bus Speed: 800 MHz

    System Info:
    Version 10.5.8
    Build 9L31a

    GraphicsDisplay
    Intel GMA X3100:

    Chipset Model: GMA X3100
    Type: Display
    Bus: Built-In
    VRAM (Total): 144 MB
    Vendor: Intel (0x8086)
    Device ID: 0x2a02
    Revision ID: 0x0003
    Displays:
    Color LCD:
    Resolution: 1280 x 800
    Depth: 32-bit Color
    Core Image: Hardware Accelerated
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Quartz Extreme: Supported
    Built-In: Yes
    Display Connector:
    Status: No display connected

    #57682

    fab4
    Participant

    Uncheck the ‘Full Screen’ checkbox.

    Uncheck the ‘Music’ checkbox.

    Scorched should run fine on your machine. My wife has a 2.0 GHz MacBook running 10.5.x and GMA3100 graphics – works fine.

    #57683

    gottyfunk
    Participant

    Hi,
    I tried that too.
    I think there is a bigger issue however…
    In the Mac version, in the Settings Menu there is no OK/Save Button. So that means that it doesn’t matter what I chose, it reverts to the default settings.
    Anyone else experience this? I’m using version 42.1 of scorched3d.

    btw, I was able to run the Windows version on my mac in an emulator program. the menu there does have an OK button. at first the program crashed, but then after changing the settings was indeed able to get it running.

    @fab4 wrote:

    Uncheck the ‘Full Screen’ checkbox.

    Uncheck the ‘Music’ checkbox.

    Scorched should run fine on your machine. My wife has a 2.0 GHz MacBook running 10.5.x and GMA3100 graphics – works fine.

    #57684

    Rommel
    Participant

    The ENTER key on your keyboard is the save changes key. This issue is documented in another thread although it doesn’t seem to be documented in the documentation.

    Recent Edit : This is the other thread I mentioned.

    viewtopic.php?f=6&t=5736

    Perhaps a sticky note should be posted to help the Mackers find this information.

    #57685

    Rommel
    Participant

    On second thought … Perhaps one of you could take the setttings screen and incorporate the save and cancel buttons into the next version update. The closer all operating system versions are, in both, form and function, the more likely it will be that anyone will be able to provide a timely and accurate reply to those requesting assistance.

    This is a good thing to consider given the circumstances.

    In the meantime, updating the online documentation and the Mac Help sticky should be completed ASAP.

    Thank you in advance for your outstanding dedication and selfless service to the game.

    #57686

    fab4
    Participant

    Rommel,

    I think you’re on the right track – there should be ‘Save’ and ‘Cancel’ buttons on the bottom of the settings screen – but there’s some odd bug in Scorched that causes these buttons to be hidden on certain Macs.

    I can confirm the ‘Save’ and ‘Cancel’ buttons appear on the many Macs in my house.

    #57687

    tumbleweed
    Participant

    I think it has to do with screen resolution sizes. The bottom of the dialog box “runs” off the screen so the buttons are not visible. If the dialog box were re-sizable then the “concern” would be fixed cross platform. I noticed this was the case when running scorched on my AA1 as it has a screen resolution of 1280×600, and comparing the dialog box to that of my desktop which is 1600×900.

    #57688

    imported_gcamp
    Participant

    The save and cancel button are off the bottom of the screen on many macs. Or rather the screen size does not let the dialog get to the appropriate size to display all of the buttons.

    I’ve just fininished compiling it on a mac mini and have moved some of the options to another tab to fix this problem. I’ll try and release this version soon.

    #57689

    fab4
    Participant

    Gavin,
    Congrats on the Mac mini purchase. Look forward to the update.

    I think the change would also be helpful for Windows users – most of the netbooks with 8.9 inch or 10.1 inch screens have a resolution of 1024 x 600.

    #57690

    imported_gcamp
    Participant

    I’ve just a couple of updates to make since the mac seems to use funny GL extensions. Then I’ll release it so you can have a look.

    #57691

    fab4
    Participant

    Will this be the first official Universal (PPC/Intel) version of Scorched3d for the Mac?

    #57692

    imported_gcamp
    Participant

    Its not universal, not even tried to do that yet. I’m guessing that will be another whole world of pain.

    The intel version test is here:
    http://sourceforge.net/projects/scorched3d/files/scorched3d/Version%2042.1/Scorched3D-42.1-intel.dmg/download

    #57693

    fab4
    Participant

    I had no luck at all running the Intel test version on my Mac mini – it would crash on startup using all graphics settings I tried, even the safe mode at 800 x 600.

    My mini is the previous version – 1.83 GHz Core2Duo with GMA 950 graphics

    So I went back to the PPC version – works with most graphics on.

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.