This topic contains 2 replies, has 0 voices, and was last updated by  Deathstryker 12 years, 8 months ago.

  • Author
    Posts
  • #3163

    hobbesme
    Participant

    Howdy all. I’ve finally installed V38.1b! Hooray! 🙂

    And man, are there some noticeable changes!

    I know, I know — you all know this already, but I’m three months behind the rest of you.

    Anyways, I want to re-map the ‘Camera No Restrict/Penetrate Landscape’ key & can’t figure out how. The help file indicates that the current key map for penetrating the landscape is the Left-ALT key, but after installation that key is mapped to the Right-ALT key.

    Although I can select that button in ‘Change Game Settings : Keys’ configuration, I cannot figure out how to map it to the Left-ALT key. I can map it to other keys. I just can’t figure out how to map it solely to the Left-ALT key.

    Trying another way, I thought I could edit the

      datakeys.xml

    file & just edit that value. However, I changed the appropriate entry, saved the file, re-opened the game, & the key settings were unchanged! 🙁

    Any advice anyone? Thanks.

    #15765

    Ebonite
    Participant

    Willis told me about the .xml edit, because that’s how he did it, but I couldn’t get it to work for me. Mine even says l.alt (or whatever the code is) now but only works off the right one. Willis simply said my computer is FUBAR, which was far truer than he could imagine.

    #15766

    hobbesme
    Participant

    @hobbesme wrote:

    I thought I could edit the

      datakeys.xml

    file & just edit that value. However, I changed the appropriate entry, saved the file, re-opened the game, & the key settings were unchanged! 🙁

    Apparently, this actually worked because when I started the game, the ‘No Camera Restrict’ was then mapped to the Left-ALT key — AND when I ALT-Tab’d back to Windows & opened the ‘Key’ mappings configurations, it now showed the key mapping as ‘ LALT’.

    So, for some reason, after I had edited the file, the game configuration did not show the update until AFTER I had started a game with the new configuration.

    #15767

    Deathstryker
    Participant

    Better results would have been to edit the one in the C:Documents and Settings.scorched3d directory 😉

    The reason it didn’t change immediately was because it was still reading the one from that directory which was unchanged.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.