This topic contains 53 replies, has 0 voices, and was last updated by  jdog 11 years, 2 months ago.

  • Author
    Posts
  • #30591

    Deathstryker
    Participant

    I just now installed the patch over v39 and all is fine to me. Both Apoc and regular Scorched work.

    #30592

    brandon
    Participant

    As you’ve asked, here are my problems:

    Compiling was all OK.

    bash-3.1$ /usr/local/games/scorched3d/bin/scorched3d
    Fatal signal: Segmentation Fault (SDL Parachute Deployed)

    Here are the information about the requirements on my pc
    Hope this helps and hope that you might help me.
    This is SEMPRON 3000+
    512 RAM
    Geforce2 400 64 RAM
    Slackware 10.2

    bash-3.1$ sdl-config –version
    1.2.9
    bash-3.1$ wx-config –version
    2.4.2
    bash-3.1$ openal-config –version
    0.0.8
    bash-3.1$ freetype-config –version
    9.7.3
    bash-3.1$ glxinfo | grep -i version
    server glx version string: 1.4 Mesa 6.5
    client glx version string: 1.4 Mesa 6.5
    OpenGL version string: 1.5 Mesa 6.5
    glu version: 1.3bash-3.1$ aclocal –version
    aclocal (GNU automake) 1.9.5
    Written by Tom Tromey

    Copyright (C) 2005 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    bash-3.1$ automake –version
    automake (GNU automake) 1.9.5
    Written by Tom Tromey .

    Copyright 2005 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    bash-3.1$ autoconf –version
    autoconf (GNU Autoconf) 2.59
    Written by David J. MacKenzie and Akim Demaille.

    Copyright (C) 2003 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    bash-3.1$ g++ –version
    g++ (GCC) 3.3.6
    Copyright (C) 2003 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    #30593

    Deathstryker
    Participant

    turn type still says “looser” instead of “loser”

    That is my “major” bug report.

    #30594

    Wowbagger
    Participant

    Help!!!

    this is what happens after install……uninstall and install again 🙁

    #30595

    cbx550f
    Participant

    Bagger – try deleting your .scorched3d directory (save your ids.xml!) – see http://www.scorched3d.co.uk/phpBB2/viewtopic.php?t=3173

    #30596

    Deathstryker
    Participant

    @cbx550f wrote:

    Bagger – try deleting your .scorched3d directory (save your ids.xml!) – see http://www.scorched3d.co.uk/phpBB2/viewtopic.php?t=3173

    He got it fixed CBX. He IM’ed me on AIM and I told him what to do.

    #30597

    cbx550f
    Participant

    @Crispy Critter wrote:

    I got it working again (still minus boid sounds, which cause crashes, as they have in v39/64-bit as well). I’ll post a writeup soon on how to get it going – and maybe try working up a FC5/64-compatible RPM as well.

    I tried debugging the boid sound crashes back when v40 was still in CVS, and quickly got lost in a maze of twisty little passages, all different.

    CC, when you post a patchset, make sure I know so I can get it in the Gentoo package.

    Also, I get that “usr/share/autoconf/Autom4te/C4che.pm line 69, line” error on one of my machines – haven’t really looked into why. (I didn’t get that when I checked out the cvs hours before release….)

    cbx

    #30598

    Wowbagger
    Participant

    Many Thanks to Deathstryker, CBX and Willis.

    😀 😀 😀

    I knew there was a good reason I had that ids.xml file saved elsewhere on my computer. 🙂

    #30599

    imported_gcamp
    Participant

    Thanks for sorting out that issue guys, I had a minor coronary when I saw 23 posts :).

    The good news is that the mods are now versioned, so for future versions the mods directory will automatically be tidied up when a new version of scorched is installed.

    #30600

    imported_gcamp
    Participant

    @cbx550f wrote:

    @Crispy Critter wrote:

    I got it working again (still minus boid sounds, which cause crashes, as they have in v39/64-bit as well). I’ll post a writeup soon on how to get it going – and maybe try working up a FC5/64-compatible RPM as well.

    I tried debugging the boid sound crashes back when v40 was still in CVS, and quickly got lost in a maze of twisty little passages, all different.

    CC, when you post a patchset, make sure I know so I can get it in the Gentoo package.

    Also, I get that “usr/share/autoconf/Autom4te/C4che.pm line 69, line” error on one of my machines – haven’t really looked into why. (I didn’t get that when I checked out the cvs hours before release….)

    cbx

    Have you tried running “autogen.sh” again or doing a “make distclean” ?

    Its probably artifacts left over from my running of autoconf.

    #30601

    imported_gcamp
    Participant

    @fab4 wrote:

    Great news Gavin.

    I downloaded the OSX source and couldn’t get it to compile – I guess the version of SDL installed on my OSX 10.4.5 machine is less than 1.2.5 and I couldn’t figure how to get past this error. I’m no C programmer. I guess it’s time to start begging for an OSX Binary 😉

    No worries, I’ll be looking at getting mac binary out very soon.

    #30602

    imported_gcamp
    Participant

    @brandon wrote:

    As you’ve asked, here are my problems:

    Compiling was all OK.

    Any chance of running scorched with the -allowexceptions flag and getting a stack trace from the core dump?

    #30603

    imported_gcamp
    Participant

    @Crispy Critter wrote:

    I got it working again (still minus boid sounds, which cause crashes, as they have in v39/64-bit as well). I’ll post a writeup soon on how to get it going – and maybe try working up a FC5/64-compatible RPM as well.

    I tried debugging the boid sound crashes back when v40 was still in CVS, and quickly got lost in a maze of twisty little passages, all different.

    Great 🙂 Let me know if you need a hand.

    Also if you have a stack trace for the crash I may be able to help (or perhaps not) :).

    #30604

    Bobirov
    Participant

    Could the v40 install package be made to clean up the .scorched3d folder? I am seeing a bunch of people get those errors due to old files being left in there. Many of them never come to the forum to figure out how to fix it. ApocHQ has been practically empty due to people getting errors due to the old mod files being left over. I am wondering if the installer could move all the old mod files over to oldmods or otherwise clean up the old files a bit to prevent these errors from happening.

    Just a thought.

    #30605

    Crispy Critter
    Participant

    More things:

    • I’ve posted a patch set and FC5 x86_64 RPMs in the main forum.
    • I don’t know jack about Gentoo – hopefully it won’t have FC5’s wackiness w.r.t. the wxGTK libraries.
    • If you look in my RPM spec file, you’ll notice that I have to run the createAMMakefile.pl script, then do the aclocal/automake/autoconf thing, then apply two last patches.
    • createAMMakefile.pl has to be run because the stock Makefiles don’t seem to have some of the data files included (like the sentrygun).
    • If you’re getting that autoconf error, remove the autom4te.cache directory and try again.
Viewing 15 posts - 16 through 30 (of 55 total)

You must be logged in to reply to this topic.