This topic contains 2 replies, has 0 voices, and was last updated by  parasti 10 years, 1 month ago.

  • Author
    Posts
  • #5857

    parasti
    Participant

    I’m not sure when this started happening, but it did not happen two or three days ago. I discovered it yesterday. Basically what doesn’t work:

    • Clicking in the landscape has no effect, the view centre doesn’t change.
    • Using the “a” key (auto-aim at cursor location) also has no effect, the yellow/green bar is not displayed and the rotation does not change.

    There is one exception to both problems. At times, the view centre does change, but the view is then centred on one of the corner buoys. Likewise, sometimes the bar is displayed and the rotation does change, but as a result the tank is facing one of the corner buoys and not the spot I was pointing at. I am not always able to reproduce this, it happens pretty much randomly and rarely.

    Everything else works. I can rotate the camera by right-clicking and moving the mouse, I can select widgets, click buttons, use the keyboard, change view centre by following my own shots with the “gun view” camera, etc. Only direct interaction with the landscape doesn’t work.

    I’m running Debian Lenny. I’ve tested 40.1d from Debian, 40.1d debug build from Debian, 40.1d RPM from this site converted to a Debian package, and a self-compiled 41beta3 and had the same problem with all of them.

    What could cause this, how could I fix it, and what should I be looking at in the code and elsewhere?

    #44832

    Irishbandit
    Participant

    @parasti wrote:

    I’m not sure when this started happening, but it did not happen two or three days ago. I discovered it yesterday. Basically what doesn’t work:

    • Clicking in the landscape has no effect, the view centre doesn’t change.
    • Using the “a” key (auto-aim at cursor location) also has no effect, the yellow/green bar is not displayed and the rotation does not change.

    There is one exception to both problems. At times, the view centre does change, but the view is then centred on one of the corner buoys. Likewise, sometimes the bar is displayed and the rotation does change, but as a result the tank is facing one of the corner buoys and not the spot I was pointing at. I am not always able to reproduce this, it happens pretty much randomly and rarely.

    Everything else works. I can rotate the camera by right-clicking and moving the mouse, I can select widgets, click buttons, use the keyboard, change view centre by following my own shots with the “gun view” camera, etc. Only direct interaction with the landscape doesn’t work.

    I’m running Debian Lenny. I’ve tested 40.1d from Debian, 40.1d debug build from Debian, 40.1d RPM from this site converted to a Debian package, and a self-compiled 41beta3 and had the same problem with all of them.

    What could cause this, how could I fix it, and what should I be looking at in the code and elsewhere?

    Check your key bindings in your settings file.

    #44833

    parasti
    Participant

    What should I be looking for? For what it’s worth, I have tested the game with the default configuration (rm -rf ~/.scorched3d), thus I am certain that this is not a configuration problem.

    #44834

    parasti
    Participant

    I found the respective code bit and it gave me a couple of ideas to try. Turns out this is a bug in GLU as shipped with Mesa. It is already fixed upstream. You can read more about this bug in Debian Bug report logs – #440137. A temporary fix for Debian Lenny users is available, see the aforementioned bug report for instructions.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.