This topic contains 21 replies, has 0 voices, and was last updated by  Irishbandit 10 years, 4 months ago.

  • Author
    Posts
  • #35782

    DeVice
    Participant

    Launching scorched3d from commandline is as simple as typing “scorched3d” in a xterm window (once the game has been successfully installed).

    Actually i believe it’s the main way to launch it, it doesn’t auto register in kde/gnome/whatever menus.

    #35783

    LeeT
    Participant

    When I try scorched3d I get: -bash: scorched3d: command not found

    #35784

    Brain Damage
    Participant

    did you run make install?

    if you did, check the folders /usr/bin or /usr/local/bin if contains a bin file called scorched3d

    if you compiled from the cvs srouces you need to create a symbolic link with

    ln -s /usr/local/games/scorched3d/bin/scorched3d /usr/bin/scorched3d

    #35785

    Irishbandit
    Participant

    I tried every thing that device and cbx said still couldnt get it to build!!
    Reminded me of trying to build under windows. So i worked on it and worked on it. finally got it!!!

    Edited configure:
    changed
    LDFLAGS=”-L/usr/X11R6/lib -L/usr/X11R6 -L/usr/local/lib”
    CPPFLAGS=”-I/usr/X11R6/include -I/usr/X11R6 -I/usr/local/include”
    LIBS=”$LIBS /usr/local/lib/libopenal.a”
    CFLAGS=”$CFLAGS `$FREEALUT_CONFIG –cflags`”
    CXXFLAGS=”$CXXFLAGS `$FREEALUT_CONFIG –cflags`”

    to:
    LDFLAGS=”-L/usr/X11R6/lib -L/usr/X11R6 -L/usr/lib”
    CPPFLAGS=”-I/usr/X11R6/include -I/usr/X11R6 -I/usr/include”
    LIBS=”$LIBS /usr/lib/libopenal.a”
    CFLAGS=”$CFLAGS `$OPENAL_CONFIG –cflags`”
    CXXFLAGS=”$CXXFLAGS `$OPENAL_CONFIG –cflags`”

    edited configure.ac
    LDFLAGS=”-L/usr/X11R6/lib -L/usr/X11R6 -L/usr/local/lib”
    CPPFLAGS=”-I/usr/X11R6/include -I/usr/X11R6 -I/usr/local/include”
    LIBS=”$LIBS /usr/local/lib/libopenal.a
    around line 133
    echo “*** environment variable to the full path to openal-config.”
    else

    CFLAGS=”$CFLAGS `$FREEALUT_CONFIG –cflags`”
    CXXFLAGS=”$CXXFLAGS `$FREEALUT_CONFIG –cflags`”

    to
    LDFLAGS=”-L/usr/X11R6/lib -L/usr/X11R6 -L/usr/lib”
    CPPFLAGS=”-I/usr/X11R6/include -I/usr/X11R6 -I/usr/include
    LIBS=”$LIBS /usr/local/lib/libopenal.a

    around line 133
    echo “*** environment variable to the full path to openal-config.”
    if test x”$use_static_openal” = x”yes”; then
    LIBS=”$LIBS /usr/lib/libalut.a”
    else
    LIBS=”$LIBS `/usr/bin/openal-config –libs`”
    fi
    CFLAGS=”$CFLAGS `/usr/bin/openal-config –cflags`”
    CXXFLAGS=”$CXXFLAGS `/usr/bin/openal-config –cflags`”

    then
    ./configure –disable-openaltest

    then:
    LIBS=”-lalut” make

    dont ask me how it worked.. And dont laugh even if its funny,or does not make sence. 😳

    After looking this over the only thing really different from Device’s patch is the

    line LIBS=”$LIBS `$FREEALUT_CONFIG –libs`”

    which i had to change to:
    line LIBS=”$LIBS `/usr/bin/openal-config –libs`”

    and that i had to point everything to /usr/lib in my case. 😳 😳

    Thanks again for all the help.

    #35786

    Irishbandit
    Participant

    New computer and used the info that DeVice posted worked like a charm. 🙂 🙂

    #35787

    Irishbandit
    Participant

    OK I wanted to install from cvs last night cause I am seeing and hearing that newest release will be sweet. Downloaded fresh cvs. So far so good read compile notes fine.
    ran createAMMakefile.pl
    chmod +x autogen.sh
    ./autogen.sh
    same old openal-config freealut-config errors!!! BAH

    So I tried ./configure –disable-openaltest
    LIBS=”-lalut” make
    Didnt help stilll died

    So I have been editing the configure.ac and that has been working for me so I tried I dont know how many different things to get it to work nothing would work. Grumbling by this time its midnight and I am tired will try again tomorrow.

    Today I deleted the cvs got a new copy same thing wont work
    ran scripts/createAMMakefile.pl
    chmod +x autogen.sh
    ./autogen.sh
    same old openal-config freealut-config errors!!!
    Tried editing configure-al.m4 that didn’t help started getting errors in the configure lines.

    😥 😥
    Found this post about building on
    amd64
    Tried what was posted worked first time.

    createAMMakefile.pl
    chmod +x autogen.sh
    ./autogen.sh
    errors out then ran
    ./configure –disable-openaltest CXXFLAGS=-lalut
    make
    sudo make install

    Worked perfectly!!! 😀 😀

    Ubuntu 7.04 Kernel 2.6.20-16-386

    Where can I post things I like and don’t like about cvs version??? I have a couple and thats only from first practice round. Getting used to new gui.

    #35788

    parasti
    Participant

    @irishbandit wrote:

    chmod +x autogen.sh
    ./autogen.sh
    errors out then ran
    ./configure –disable-openaltest CXXFLAGS=-lalut

    The error occurs because autogen.sh runs configure. Instead of the three commands above, you should be able to do just

    sh autogen.sh --disable-openaltest CXXFLAGS=-lalut
    #35789

    Irishbandit
    Participant

    @parasti wrote:

    @irishbandit wrote:

    chmod +x autogen.sh
    ./autogen.sh
    errors out then ran
    ./configure –disable-openaltest CXXFLAGS=-lalut

    The error occurs because autogen.sh runs configure. Instead of the three commands above, you should be able to do just

    sh autogen.sh --disable-openaltest CXXFLAGS=-lalut

    TY new to linux did not know how to pass commands to autogen.sh Thank-you.

Viewing 8 posts - 16 through 23 (of 23 total)

You must be logged in to reply to this topic.