This topic contains 3 replies, has 0 voices, and was last updated by  imported_gcamp 7 years, 2 months ago.

  • Author
  • #7445


    I aam new to linux but the problem is dependancy hell, so when I go to install Scorch 3D I get

    Transaction Error
    openal-0.0.9-0.13.20060204cvs.el5.x86_64 requires
    scorched3d-43.2a-1.i686 requires

    So I try to install OpenAL using yum and get:

    [root@Stargate Desktop]# yum install openal
    Loaded plugins: refresh-packagekit, rhnplugin
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package openal.x86_64 0:0.0.9-0.13.20060204cvs.el5 set to be updated
    --> Processing Dependency: for package: openal-0.0.9-0.13.20060204cvs.el5.x86_64
    --> Finished Dependency Resolution
    Error: Package: openal-0.0.9-0.13.20060204cvs.el5.x86_64 (epel)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    So then I try finding the package with yum and get:

    [root@Stargate Desktop]# yum install libesd
    Loaded plugins: refresh-packagekit, rhnplugin
    Setting up Install Process
    No package libesd available.
    Error: Nothing to do

    so then I find and try installing esound from a website using RPM and get:

    Test Transaction Errors: file /etc/esd.conf from install of esound-libs-1:0.2.41-1.fc10.x86_64 conflicts with file from package esound-1:0.2.20-2.i586

    All that work and no joy, they just made Linux too hard to be of practical use for gaming IMHO.



    If there is any linux distro that be compatible with scorched3d that is fedora/redhat.

    I successfully installated S3d on centos5.3 (which is 100% same as Red Hat Enterprise 5.3). Guess Red Hat Enterprise 6.0 is not difference.
    libesd is not needed. This is some stupid RH dependency problem againnnnnnn. you need openal.
    If i have time i could make packages for RHEL.



    I think I am gonna re-provision the system and dual boot with Windows for gaming. My guess is that the libraries and Red Hat 6 O/S is just too new. I Had that problem when I installed XP X64 when it first came out.



    Install the ia32-libs if you are using the rpm from its a i686 package. Might help, you could also install the version from repo and then remove it and then try the latest release. Just some ideas.



    That RPM is actualy built on a 32bit version of fedora, but I know the enterprise version lags behind a bit on functionality. If would definitely work on fedora.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.