This topic contains 14 replies, has 0 voices, and was last updated by  ArmorWraith 8 years, 2 months ago.

  • Author
    Posts
  • #6918

    ArmorWraith
    Participant

    That points out the tag, what did i do wrong!!

    I have both tags, open and close..

    It was working fine before i moved a few weaps around, but now it says parse error!

    Unggghh staying up too late, starting to make mistakes..

    #56512

    Thrax
    Participant

    If it can wait till after-noon, i get back from work at 4:30 mountain time.

    I can look it over then for you.

    #56513

    ArmorWraith
    Participant

    Ok Here it is..dont laugh at my unorganization…

    I work at 4;00 central time till 9, so i wont be able to answer any questions till late :(.

    Laptop came in merge when i was playing, and used net beans to help, he said line 2084, but when i reference that line, it does not appear broken. He also said it would be in the orbital attack weapon, which i looked over…its all correct. Dang i got so excited!

    Ty though for your help laptop, i am still dedicting weapon, and if it is orbital attack, ty so much!

    #56514

    Laptops Daddy
    Participant

    no, not orbital attack. orbital assault. its the closing tag. i may have had the line number wrong, i copied and pasted.

    #56515

    Rommel
    Participant

    When all else fails, start whacking.

    you can cut out entire weapons and paste them into a “SAVE” file one at a time and find which weapon is causing the problem this way.

    Yes, it is crude, but it will allow you to figure out where the problem is instead of just waiting for someone else to show you.

    Good luck

    #56516

    ArmorWraith
    Participant

    yes you found it, ty so much, it was orbit assult, i specifically remember moving that one!!! Ty It works Now 😀

    #56517

    ArmorWraith
    Participant

    Ok i Have a new problem, and yes i have scoured the documents, forums and google.

    My mod works great in a custom game where i click “give all weapons’,

    But when i go to play a custom “buy on round normal game”, it freezes when i click to buy a weapon in the buy menu. It exits and says scorched 3d process terminated unsupectingly… then it asks if i want to load failsafe settings..

    Youll prolly need to look at my mod files eh, how can i transfer them? a server wont work, ive tried. I dont have any accounts for sourceforge or any other download site. I have it compressed and zipped ready to go, just point me a way to send it 😀

    #56518

    Rommel
    Participant

    I’m not able to look through your whole mod. More detail perhaps.

    #56519

    Irishbandit
    Participant

    try running scorched with -allowexceptions
    ie in windows click start run then paste:
    “c:Program FilesScorched3Dscorchedc.exe” -allowexceptions

    on linux its the path to scoreched3d
    scorched3dc -allowexceptions
    then it should give you the error.

    #56520

    ArmorWraith
    Participant

    no luck, gave me the error report, same, just didnt ask me to load failsafe settings for scorch3d. 🙁

    I wonder, if too many weapons.. or if its a bot buying error, i dont see why though i havent modified the bots yet in any way.

    #56521

    Rommel
    Participant

    Check your server log file and your client log file. I had the same issue after the other server interface was removed. I think it was Robert Hand that told me where to look. The forums are a most excellent source, although finding what you want is sometimes a bit more difficult than expected.

    If a search does not give you want you want, try a different search string.

    Sometimes it takes some doing.

    #56522

    Thrax
    Participant

    Working thru it now somewhat. I’m finding that you duplicated many of
    the weapons, then simply made the original one unbuyable. This did
    increase the total weapon count internally by a lot, that may be part of it.

    Both the server log and the client log show nothing when the server crashes,
    It may be getting overloaded trying to store that many weapons. After work
    today, i’ll test out pruning some of the obsolete and unavailable weapons.

    but i will say, you did well on getting the size back down, and the new textures
    and models do look great. As this was only your first try at modding, you can
    definately keep a lot of these if you redo another one from scratch someday.

    I’ll keep you posted.

    #56523

    ArmorWraith
    Participant

    Yes i created some new weapons since yesterday, some fireworks in my area inspired me, i think i will instead of modding, make projectile models,custom explosions, and create a weapons library. I may try to mod after i figure out all of the code. Ty for your hard work, and the compliments.

    Kanga

    #56524

    ArmorWraith
    Participant

    Destiny
    10
    Let Destiny Decide your shielding!!
    shield.bmp
    shield/activate3.wav
    1
    3000
    30
    1

    RANGE(2,5)
    RANGE(90,150)
    false
    true
    true

    RANGE(0.1,0.9)
    RANGE(0.1,0.9)
    RANGE(0.1,0.9)

    shield/hit.wav
    RANGE(5,10,25)
    RANGE(0.1,0.9)

    Ok me an my bright ideas scoured the wiki for tings i may have overlooked, and i found one, random values!!

    Now i realize you can only apply theese to float alues, RGB for shield color is float value right?

    I keep getting an error for that particular part of the shield code, parser error. I believe that it cannot be randomized as of this version.

    #56525

    ArmorWraith
    Participant

    Destiny
    10
    Let Your Destiny Decide Your Shielding!!
    shield.bmp
    shield/activate3.wav
    1
    3000
    30
    1

    RANGE(2,5)
    RANGE(90,150)
    false
    true
    true

    0.9
    0.1
    0.6
    shield/hit.wav
    RANGE(5,10,25)
    RANGE(0.1,0.9)

    then when i changed it to this, this error occured.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.