This topic contains 10 replies, has 0 voices, and was last updated by  ChmOOrecK 11 years ago.

  • Author
    Posts
  • #4715

    RasKolniKoV
    Participant

    Hi,

    I think that implementing an FPS limiter would be great. Actually I need it because my laptop gets too hot while playing this game and actually, as linux wireless drivers aren’t very well yet, my connectiong often drops because of too high CPU usage.

    I think it would be easy to implement. I’ve been browsing the CVS and I think that I can do a fast patch by myself, but I thought that it would be better if you did it by yourself so I don’t mess up your code.

    Moreover, are there any plans for a future release?

    Thanx 🙂

    #32286

    Deathstryker
    Participant

    Just want to let you know that the dev may not be able to reply to you for a few days as he’s elsewhere at the moment. Just wanted to let you know before you felt ignored. If you want to know more about plans you can look at the ToDo list if you haven’t already (I’m sure you have). Other than that, there aren’t too many other ideas that aren’t already on there.

    #32287

    RasKolniKoV
    Participant

    Ok 🙂

    Anyways, I’ve studied a bit how does the code is organized and decided to do it by myself. I’ll send the dev a patch as soon as I’m finished.

    Thanx.

    #32288

    parasti
    Participant

    Why don’t you just use vertical synchronization?

    #32289

    RasKolniKoV
    Participant

    Parasti, how can I set Vsynch in Scorched? That would be a nice and easy solution 🙂

    Moreover, I was trying to build scorched but, despite I have development packages of OpenAL and Alut installed, I get this:

    ../sound/SoundBufferStaticWav.cpp:80: undefined reference to `alutLoadWAVFile'
    ../sound/SoundBufferStaticWav.cpp:96: undefined reference to `alutUnloadWAV'
    ../sound/SoundBufferStaticWav.cpp:80: undefined reference to `alutLoadWAVFile'
    ../sound/SoundBufferStaticWav.cpp:96: undefined reference to `alutUnloadWAV'
    #32290

    parasti
    Participant

    @raskolnikov wrote:

    Parasti, how can I set Vsynch in Scorched? That would be a nice and easy solution 🙂

    I believe that depends on what kind of video board you’re using. For instance, if you’re using an NVIDIA like me, you’d either set the __GL_SYNC_TO_VBLANK environment variable to a non-zero value or (the simple way) use the nvidia-settings utility and modify the OpenGL settings. But really, check the documentation of your graphics driver.

    Moreover, I was trying to build scorched but, despite I have development packages of OpenAL and Alut installed, I get this:

    ../sound/SoundBufferStaticWav.cpp:80: undefined reference to `alutLoadWAVFile'
    ../sound/SoundBufferStaticWav.cpp:96: undefined reference to `alutUnloadWAV'
    ../sound/SoundBufferStaticWav.cpp:80: undefined reference to `alutLoadWAVFile'
    ../sound/SoundBufferStaticWav.cpp:96: undefined reference to `alutUnloadWAV'

    I can only tell that it fails the linking phase. Headers are found and are valid but not the library files (usually located in /usr/lib/).

    #32291

    RasKolniKoV
    Participant

    I already knew that the problem was in the linking fase, but I don’t know whether it’s Scorched’s fault or it’s my system’s fault. Maybe the ./configure is wrong or something like that.

    I’ll try setting Vsynch as you say, but I’ll probably make a script to set it only for S3D because I don’t want it for the rest of apps.

    #32292

    parasti
    Participant

    @raskolnikov wrote:

    I already knew that the problem was in the linking fase, but I don’t know whether it’s Scorched’s fault or it’s my system’s fault. Maybe the ./configure is wrong or something like that.

    I just tried to build the game myself and got the same error. It’s the game’s fault. Looks like no checks for ALUT libraries are performed except those of the compiler itself. A temporary fix: add ‘-lalut’ to LIBS in ./src/scorched/Makefile, line 1679.

    #32293

    imported_gcamp
    Participant

    The game uses openal-config to get the libs line, it looks like an issue whith that non-scorched provided file.

    I have now put a framerate limiter into the CVS version and will be released in the next version.

    #32294

    parasti
    Participant

    @gcamp wrote:

    The game uses openal-config to get the libs line, it looks like an issue whith that non-scorched provided file.

    Not sure it’s an issue. ALUT is not part of OpenAL. (At least not anymore?)

    #32295

    RasKolniKoV
    Participant

    Maybe the problem is that Debian delivers alut and openal in different packages…

    Lots of thanks gcamp for adding that feature and for developing this enjoyable game 🙂

    #32296

    ChmOOrecK
    Participant

    @gcamp wrote:

    I have now put a framerate limiter into the CVS version and will be released in the next version.

    Great. THANKS !!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.