This topic contains 21 replies, has 0 voices, and was last updated by  imported_gcamp 10 years, 6 months ago.

  • Author
    Posts
  • #5411

    Picci
    Participant

    i would like to host a server, but i’m not sure if the physical Firewall in the router will block the incoming connections… are there specific ports i have to open ?

    i know i can “rout” incoming requests on certain ports to the computer where i’m running scorched….

    … will try running an xmas mod server called “X-Mas Test Server 1.0” or something like that today… if you see it running, plz join just to see if it works 😉 😀

    thx

    #41008

    cbx550f
    Participant

    See http://www.scorched3d.co.uk/wiki/index.php/Server_Behind_Router and http://www.scorched3d.co.uk/wiki/index.php/Server_Connection_Troubleshooting

    Note that the ports on your firewall/router need to be not only open, but also forwarded to the PC that is running the server.

    HTH

    #41009

    Picci
    Participant

    ehm… well, sort of working

    i set the router and that works.
    i set windows firewall and that works.
    i shut down zone alarm, since that was the only thing i didn’t know how to configure (ZA v.7, anyways it was set to allow everything on/from scorched)

    and this is what i get in the http://www.scorched3d.co.uk/servers/servers.php page:

    Server Unknown 87.5.***.***:27270 Unknown – –
    – – – –

    (the *** change every time i restart the router or mess up something, because of the dhcp…)

    anything i can do to get the name of the server up ?

    #41010

    Brain Damage
    Participant

    add the port: 27393/udp to the router/firewall/nat/whatever

    i should add that to the docs, but i’m not sure if the last port is really requied; because it’s not in the docs shipped with the game (wich may be outdated), but if i don’t open it, i can’t host, anyone experienced being able to host without opening such port?

    anyway it’s always

    base port: tcp (default 27270)
    base port +1: udp (default 27271)
    base port + 123: udp (default 27393)

    #41011

    Picci
    Participant

    tried , opened port 27393 on router, and firewall, i still get the IP in the list
    but no server name or game details….

    i tried turning off all firewalls: no results,
    i configured win firewall to open 27270 27271 27393 on both TCP and UDP: no results

    bah

    #41012

    BigBear
    Participant

    @picci wrote:

    i set the router and that works.
    i set windows firewall and that works.
    i shut down zone alarm, since that was the only thing i didn’t know how to configure (ZA v.7, anyways it was set to allow everything on/from scorched)

    Err question. Why oh why do you have Windows firewall AND Zonealarm running at the same time? That can never help! Close that Windowze crap down when you have a decent firewall up already. Setting ZA is really easy. Just open the control center, click on program control and grant scorched.exe server rights.

    #41013

    Deathstryker
    Participant

    I forgot to mention in the wiki that the process for ZoneAlarm is the same for version 7. I will add that.

    And you don’t have to worry about Windows Firewall if you’re not connected through a LAN through a gateway computer.

    One thing I don’t understand is that when I ran a server today on my comp that was connected directly to the internet, I tried the default port of 27270 (default) with no firewalls running (don’t have a router) and it didn’t go through (I’m wondering if he’s having the same problem). However, when I tried 2727, it went through and my server appeared in the server list on this site. Anyone know what’s up with that?

    #41014

    cbx550f
    Participant

    I had the same thing the other day – turned out I had a scorched server (v41) running in the background.
    I didn’t recall starting it…. but it was there. 😉

    #41015

    Deathstryker
    Participant

    @cbx550f wrote:

    I had the same thing the other day – turned out I had a scorched server (v41) running in the background.
    I didn’t recall starting it…. but it was there. 😉

    Nah… I was running the release build v40.1d. Wanted to play against someone else. It was odd though.

    #41016

    Picci
    Participant

    hey

    windows firewall is off
    ZA is off
    router firewall is off

    same result:

    it goes to the serverlist, but with no name or game data…

    #41017

    cbx550f
    Participant

    It’s gotta be something goofy with the port forwarding on the router… you’re not using a non-default port on the server are you?

    #41018

    Picci
    Participant

    27270 27271 i also opened 27393 as bd said…

    #41019

    cbx550f
    Participant

    @picci wrote:

    27270 27271 i also opened 27393 as bd said…

    To be clear: Are they forwarded or just opened?

    #41020

    Picci
    Participant

    @cbx550f wrote:

    @picci wrote:

    27270 27271 i also opened 27393 as bd said…

    To be clear: Are they forwarded or just opened?

    forwarded

    #41021

    cbx550f
    Participant

    k, just making sure. 😉

    It just seems SO much like one of those problems I have had and then noticed that I missed something obvious. 😉 (Like the day at work recently when I was having trouble forwarding to an internal video conferencing machine… I finally noticed I had the ip was .32 instead of .23 lol.

    Pix, I’m sure this can be beaten. It may be worth a shot to reset the router to default settings and give it a fresh try. (I know it sounds stupid, but worth a shot…)

    Also worth a shot, as an experiment: Can you bypass the router and connect directly to try it out? It would at least narrow it down to the PC or the router.

    Another also: Be careful when refreshing the server list soon after starting the server, it can take a minute or two before that list knows the info from the router.

    gl,
    cbx

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.