This topic contains 3 replies, has 0 voices, and was last updated by  kyrsjo 13 years, 2 months ago.

  • Author
    Posts
  • #2741

    kyrsjo
    Participant

    Anybody having any luck with using the FC2 RPM? Im compiling it right now, just hoping that work. When i try to start the game, it just complains about my graphic adapter, sets it to “safe”, but it dont work then either…

    ATI mobility 16 MB
    P3 866 Mhz CPU

    Worked nice on fc1…

    #12391

    cbx550f
    Participant

    I’ll bet the rest of my beer that it’s just that your X display is set to 16 bit – Scorched needs 24 bit. Check your /etc/X11/XF86Config (actually, I think Fedora uses /etc/X11/XF86Config-4, IIRC), but check for:
    “DefaultColorDepth 24”

    Cheers!

    /cbx

    (Oops, after that cheers, my beer is empty – so if I’m wrong you’re out of luck)

    #12392

    kyrsjo
    Participant

    That was it. Adjusted the number of colours to “millions”, and pow! It worked. Maybe the RPM was just fine, but now i the source worked fine anyway, so…

    #12393

    imported_gcamp
    Participant

    If you want to run in 16 bit color for some reason you may need to adjust the depth buffer to match the screen depth. i.e. 16 bits. You can do this in the display.xml file in ~/.scorched3d/display.xml

    I’ve worked around this in the latest version.

    #12394

    kyrsjo
    Participant

    No no. It was just set to 16 bit without my knowing. Don’t ask me why.

    But now there is another problem: The “status” boxes in the screens cornes flickers a whole lot! And iv’e been playing like hell with the gfx-settings…

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.