This topic contains 5 replies, has 0 voices, and was last updated by  M. O. 12 years, 11 months ago.

  • Author
    Posts
  • #2983

    M. O.
    Participant

    HtmlHelpDialog.cpp:58: error: invalid static_cast from type `void (HelpFrame::*)()’ to type `void (wxEvtHandler::*)(wxCommandEvent&)’
    HtmlHelpDialog.cpp:59: error: invalid static_cast from type `void (HelpFrame::*)()’ to type `void (wxEvtHandler::*)(wxCommandEvent&)’
    HtmlHelpDialog.cpp:60: error: invalid static_cast from type `void (HelpFrame::*)()’ to type `void (wxEvtHandler::*)(wxCommandEvent&)’
    HtmlHelpDialog.cpp:61: error: invalid static_cast from type `void (HelpFrame::*)()’ to type `void (wxEvtHandler::*)(wxCommandEvent&)’
    make[2]: *** [HtmlHelpDialog.o] Error 1
    make[2]: Leaving directory `/home/brian/tmp/scorched/src/scorched’
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/brian/tmp/scorched/src’
    make: *** [all-recursive] Error 1

    Could use a little help.
    😯 😕

    #14290

    Anonymous
    Participant

    slaps face
    got it.

    #14291

    M. O.
    Participant

    Got it compiled fine but onthing I noticed now is that after playing a little while if I exit the game it leaves the process open using top. eating up cpu cycles. may be a bug not sure but using the precompiled version it doesn’t do that. Configure log is attached make produced no errors

    #14292

    M. O.
    Participant

    bump

    #14293

    M. O.
    Participant

    bash-2.05b$ glxinfo | grep -i version
    server glx version string: 1.3
    client glx version string: 1.3
    OpenGL version string: 1.5.2 NVIDIA 66.29
    glu version: 1.3

    bash-2.05b$ wx-config –version
    2.4.2

    bash-2.05b$ freetype-config –version
    9.7.3

    bash-2.05b$ sdl-config –version
    1.2.8

    bash-2.05b$ g++ –version
    g++ (GCC) 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk)

    bash-2.05b$ make –version
    GNU Make 3.80

    bash-2.05b$ autoconf –version
    autoconf (GNU Autoconf) 2.59

    bash-2.05b$ automake –version
    automake (GNU automake) 1.9

    bash-2.05b$ aclocal –version
    aclocal (GNU automake) 1.9

    #14294

    cbx550f
    Participant

    No idea offhand on this one, MO…. However, I’m curious, what did you do to fix the compile error?

    Perhaps there’s a CFLAG you need to pass along so scorched gets compiled properly for your SMP machine? Don’t know much about SMP, but it’s a thought.

    /cbx

    #14295

    M. O.
    Participant

    MDK comes with wxGTK2.4 & 2.5 uninstalled 2.5 and installed 2.4. that fixed the compile.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.