This topic contains 20 replies, has 0 voices, and was last updated by  fab4 9 years, 10 months ago.

  • Author
    Posts
  • #6066

    montymintypie
    Participant

    Ok, I am having trouble compiling a Mac version of Scorched3D (I want the latest version 😀 ) Whenever I run the configure script, it gives me this message:

    *** The openal-config script installed by OpenAL could not be found
    *** Make sure openal-config is in your path, or set the OPENAL_CONFIG
    *** environment variable to the full path to openal-config.
    configure: error: *** Can't find the openal library. Try: http://www.openal.org/

    The problem is, I already have OpenAl! I even got the latest version off the website, reinstalled, and restarted, and it still doesn’t work! I also did a search, and the only copy of openal-config was in the scorched directory. I really want to play the latest version on the Mac, please help! Thanks in advance,

    Will

    #46887

    cbx550f
    Participant

    Try copying this on the commandline:

    OPENAL_CONFIG="./scripts/openal-config" ./configure

    (I’m thinking it should be looking there for it anyway… I’ll check)

    cbx

    #46888

    imported_gcamp
    Participant

    If you give me a day I will commit the latest changes to the build scripts which support framework building for OSX. It makes things a whole lot easier to build on the mac.

    #46889

    imported_gcamp
    Participant
    #46890

    montymintypie
    Participant

    It still didn’t work 🙁 Any ideas? It still wants OpenAl, but everything else works. (I followed the instructions to the letter)

    #46891

    imported_gcamp
    Participant

    Post the config.log file.

    #46892

    Hiroyuki
    Participant

    Might be an idea to add my problems to this thread instead of in the news… The config.log is in there….

    Anyways, it seems as if Apple has done some changes to the OpenAL in the new Leopards…

    #46893

    montymintypie
    Participant

    Here it is, compressed as .zip because .log was rejected as a filetype.

    #46894

    imported_gcamp
    Participant

    This is the error.

    configure:3703: checking for openal-config
    configure:3734: result: no
    configure:3746: error: *** Can't find the openal library. Try: http://www.openal.org/

    You’ve either not set the path up correctly or I’ve missed a step.
    Try :-

    chmod +x osx/config/*config

    Now try again.

    #46895

    montymintypie
    Participant

    When do I type that? I’m relatively new to source building, and I’m not sure when to input the command.

    #46896

    cbx550f
    Participant

    do that right before you do “sh ./autogen.sh” or “./configure” (whichever one you are using… it will only need to be done once)

    I think that would only apply to the recent CVS version (?)
    If that doesn’t work, try “chmod +x scripts/openal-config”

    #46897

    fab4
    Participant

    The binaries were uploaded a week ago, and work fine on my G4 OSX 10.4.11 system

    #46898

    montymintypie
    Participant

    Tried both, and it still didn’t work! 😡 I also got the latest binaries, but instead of music I get a stupid hissing noise (like static). Also, the graphics are really slow, yet on the previous version, with the same settings, they were perfect.

    #46899

    fab4
    Participant

    I hear white noise on my Mac also – I think the music player is broken. You can disable the music from the Scorched Preference screen. The ambient sounds and explosion sounds work fine.

    Scorched graphics have gotten more complex – if you’re not happy with the performance, then check the Settings – and select Faster Settings.

    #46900

    imported_gcamp
    Participant

    Thanks fab, that pretty much sums things up. The graphics have moved on, you can turn them down to equivilent to the previous version to speed things up.

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.