This topic contains 2 replies, has 0 voices, and was last updated by  Crispy Critter 11 years, 5 months ago.

  • Author
    Posts
  • #4364

    Crispy Critter
    Participant

    I’m getting random crashes on the AMD64 system that I’ve just put together.

    System: Shuttle SN21G5
    integrated nVidia GeForce 6100
    CentOS 4.3 x86_64
    kernel modified (PCI IDs added) to support audio hardware
    OpenAL 0.0.8
    FreeALUT 1.0.1

    I’m just playing in single-player target practice.

    I did a “ulimit -c unlimited” to allow core dumps, and got one. Here’s the backtrace:

    #0  0x000000397f62e2ed in raise () from /lib64/tls/libc.so.6
    #1 0x000000397f62fa3e in abort () from /lib64/tls/libc.so.6
    #2 0x000000397f662d41 in __libc_message () from /lib64/tls/libc.so.6
    #3 0x000000397f668098 in malloc_consolidate () from /lib64/tls/libc.so.6
    #4 0x000000397f6685aa in _int_free () from /lib64/tls/libc.so.6
    #5 0x000000397f668b66 in free () from /lib64/tls/libc.so.6
    #6 0x00000039823ae19e in operator delete () from /usr/lib64/libstdc++.so.6
    #7 0x00000000004e61b5 in ~NetBuffer (this=0x7c63b0) at ../coms/NetBuffer.cpp:56
    #8 0x000000397f630c65 in exit () from /lib64/tls/libc.so.6
    #9 0x000000397f61c4c2 in __libc_start_main () from /lib64/tls/libc.so.6
    #10 0x000000000041409a in _start ()
    #11 0x0000007fbffff7a8 in ?? ()
    #12 0x000000000000001c in ?? ()
    #13 0x0000007fbffffa6f in ?? ()
    #14 0x0000007fbffffa82 in ?? ()
    #15 0x0000007fbffffa92 in ?? ()

    (etc.)

    I’ve had it happen twice at that location in ~NetBuffer, but I’ve had crashes elsewhere as well.

    I doubt it’s a memory problem, since I can successfully compile kernels.

    Any suggestions?

    #28699

    ChmOOrecK
    Participant

    @Crispy Critter wrote:

    I doubt it’s a memory problem, since I can successfully compile kernels.

    maybe try memtest over night ? (just to be sure)

    P.S. Welcome on Shuttle’s barbones – SN95G5 here…

    P.S.2. 1st place for help with them: forums.sudhian.com 😉

    P.S.3. I don’t have any problems with scorched3d (Gentoo amd64)

    #28700

    Crispy Critter
    Participant

    Well, it looks like I may need to go the Gentoo route, or perhaps wait for v40. I’m really not looking forward to installing Gentoo. Yes, I’m a dyed-in-the-wool Red Hat type (preferring CentOS to Fedora), though I have some Debian kicking around, and Ubuntu on one laptop.

    This new box is too bleeding-edge for CentOS (e.g. I had to modify the kernel for audio, the kernel doesn’t support hard disk S.M.A.R.T. reporting for SATA drives, and then there are the S3D crash problems. I then tried 32-bit CentOS 4.3, and it had a “runaway keyboard” problem with auto-repeat under X.

    Then came Fedora Core 5. Well, S3D version 39 and gcc 4 on x86_64 simply don’t get along. I tried fixing all the nagging gcc4-related problems, and eventually gave up. Remember, folks, on AMD64, sizeof(int) != sizeof(void *) or any other pointer type. FYI, sizeof(int) = 4, sizeof(long) = 8, sizeof(void *) = 8. Also, gcc 4 doesn’t like extra qualification of member functions in header files. Gcc 4 takes pedantic to a whole new level.

    I managed to compile everything on gcc 3.2, only to find that the packaged wxGTK wanted the GCC 4 libstdc++, and there was some other undefined reference (I think related to pango). Also, the standard wxGTK on FC5 wants Unicode (which meant I had to modify the configure script to set –unicode=no when running wx-config, and install the compat-wxGTK packages). I suppose I could build a special wxGTK under gcc 3.2 with –prefix=/crispy or some such…

    As for Shuttle cubes, I already have an SK41G with an Athlon XP 2100+ (I only run S3D on Windows 2000 with that box). The SN21G5 is very promising if I can get beyond the bleeding-edge teething problems – I’m running it with an Athlon 64 X2 3800+ and 2 GB of RAM, and I’m flabbergasted at how cool the CPU runs even with both cores running flat-out. The temperature stays at 40 C no matter what, and I believe the sensor reading, since the air coming from the CPU fan is barely above room temperature, the air from the power supply fan is slightly warmer, and the cooling plate on top of the CPU is cooler to the touch than the hard drive. The CPU fan just lopes along at its lowest speed, whisper-quiet.

    I had memory issues with the RAM that I originally bought – it was Corsair ValueSelect DDR400. I had Linux installer crashes with it, and when I managed to install it in text mode, I still couldn’t rebuild a kernel – the compiler would segfault. Then I tried memtest86+, and it almost instantly showed there was trouble. Back went the Corsair modules, and in their place is some Kingston ValueRAM, also DDR400. No more install or compile problems with it. Funny thing is, I have Corsair ValueSelect in three other boxes working just fine. Go figure. I still ought to give it an overnight check with memtest86+ though.

    I have a couple of weeks to decide whether I want to install XP Pro 64-bit on it or return the unopened OEM pack to the store. I’m leaning towards returning the XP, though. I’ve already got XP Pro (32-bit of course) on the T30 laptop…

    #28701

    Crispy Critter
    Participant

    I figured out that I just needed to add -lpango-1.0 -lpangox-1.0 -lalut to src/scorched/Makefile and got my gcc3.2-compiled S3D to run on Fedora Core 5. However, I ran into the same crash problems that I had on CentOS 4.3.

    I’ve noticed that some of the crashes featured a message about a corrupted doubly-linked list.

    I’ve found that turning off the boid sounds seems to eliminate the crashing, so I may show up tonight in 64-bit mode.

    Even though the linker warned about libstdc++ conflicts, the game seems to run.

    Also, I ran memtest86+ overnight last night, and got no errors whatsoever.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.