This topic contains 13 replies, has 0 voices, and was last updated by  Hiroshima DREAD 6 years, 10 months ago.

  • Author
    Posts
  • #7383

    GAZ082
    Participant

    Hi! I’m trying to install 43.1c but playdeb keeps installing the 42 version. Is there a direct link to the 43.1c x64 deb?

    Thanks!

    #61979

    Irishbandit
    Participant

    Sorry I have not been on this week. Getdeb is down it appears (yet again). So it downloads 42 from the ubuntu repos. Here is a page on how to use a mirror of getdeb.
    http://www.webupd8.org/2010/05/getdeb-playdeb-repositories-down-what.html

    If you want to dl and install the debs directly
    http://mirrors.dotsrc.org/getdeb/ubuntu/pool/games/s/scorched3d/
    You need
    http://mirrors.dotsrc.org/getdeb/ubuntu/pool/games/s/scorched3d/scorched3d-data_43.1c~dfsg-1~getdeb1_all.deb
    and
    http://mirrors.dotsrc.org/getdeb/ubuntu/pool/games/s/scorched3d/scorched3d_43.1c~dfsg-1~getdeb1_amd64.deb

    Hope this helps. Sorry it taking so long for a reply.

    #61980

    Hiroshima DREAD
    Participant

    hi!

    im pretty newbie with linux based world.
    but have already managed to get my studio to work and so on.

    found new version of my childhood favorite game aka Scorched Earth!!
    but i want to play online.

    and when i try to upgrade this 42.1 to 43.1c nothing happends.
    all the packaged i tried to download it says error.

    i know i dont have 64bit. and this is ubuntu 10.04.
    so which package i should download or how can i get this to work??
    can anybody help me littlebit.

    thank you!

    #61981

    Strelok
    Participant

    1.Open the terminal and type this

    sudo gedit /etc/apt/sources.list

    2.It will open the text editor with every mirror that ubuntu uses to upgrade itself,add this in the bottom:

    deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps
    deb-src http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps
    deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games
    deb-src http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games

    If you have a different version you must change the name (previous versions/lucid for 10.04/maverick for 10.10)

    3.Save the file and exit.
    4.Type in the terminal:

    sudo apt-get update

    It will search for ubuntu updates using the mirrors

    5.To upgrade your game type now:

    sudo apt-get upgrade

    6.Enjoy!!!

    #61982

    Thrax
    Participant

    However, the version you are trying to build is out-dated and missing features.

    The source for the most recent version is retrievable from the sourceforge
    database. Instead of solving how to build something that won’t work with
    the current servers, work together and get thing’s sorted for those that want
    to join in with the rest of us.

    #61983

    Strelok
    Participant

    @thrax wrote:

    However, the version you are trying to build is out-dated and missing features.

    The source for the most recent version is retrievable from the sourceforge
    database. Instead of solving how to build something that won’t work with
    the current servers, work together and get thing’s sorted for those that want
    to join in with the rest of us.

    viewtopic.php?f=6&t=6341

    #61984

    Hiroshima DREAD
    Participant

    thank you!!

    but came this

    tomyillnigga@STUDIO42:~$ sudo gedit /etc/apt/sources.list
    [sudo] password for tomyillnigga:
    tomyillnigga@STUDIO42:~$ sudo apt-get update
    Hit http://security.ubuntu.com lucid-security Release.gpg
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
    Hit http://security.ubuntu.com lucid-security Release
    Hit http://fi.archive.ubuntu.com lucid Release.gpg
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
    Get:1 http://fi.archive.ubuntu.com lucid-updates Release.gpg [198B]
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
    Ign http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
    Hit http://fi.archive.ubuntu.com lucid Release
    Hit http://security.ubuntu.com lucid-security/main Packages
    Get:2 http://fi.archive.ubuntu.com lucid-updates Release [44.7kB]
    Hit http://security.ubuntu.com lucid-security/restricted Packages
    Hit http://security.ubuntu.com lucid-security/main Sources
    Hit http://security.ubuntu.com lucid-security/restricted Sources
    Hit http://security.ubuntu.com lucid-security/universe Packages
    Hit http://security.ubuntu.com lucid-security/universe Sources
    Hit http://security.ubuntu.com lucid-security/multiverse Packages
    Hit http://security.ubuntu.com lucid-security/multiverse Sources
    Hit http://fi.archive.ubuntu.com lucid/main Packages
    Hit http://fi.archive.ubuntu.com lucid/restricted Packages
    Hit http://fi.archive.ubuntu.com lucid/main Sources
    Hit http://fi.archive.ubuntu.com lucid/restricted Sources
    Hit http://fi.archive.ubuntu.com lucid/universe Packages
    Hit http://fi.archive.ubuntu.com lucid/universe Sources
    Hit http://fi.archive.ubuntu.com lucid/multiverse Packages
    Hit http://fi.archive.ubuntu.com lucid/multiverse Sources
    Get:3 http://fi.archive.ubuntu.com lucid-updates/main Packages [356kB]
    Get:4 http://fi.archive.ubuntu.com lucid-updates/restricted Packages [3,240B]
    Get:5 http://fi.archive.ubuntu.com lucid-updates/main Sources [139kB]
    Get:6 http://fi.archive.ubuntu.com lucid-updates/restricted Sources [1,443B]
    Get:7 http://fi.archive.ubuntu.com lucid-updates/universe Packages [155kB]
    Get:8 http://fi.archive.ubuntu.com lucid-updates/universe Sources [59.1kB]
    Get:9 http://fi.archive.ubuntu.com lucid-updates/multiverse Packages [7,366B]
    Get:10 http://fi.archive.ubuntu.com lucid-updates/multiverse Sources [3,677B]
    Fetched 769kB in 3s (193kB/s)
    Reading package lists… Done
    tomyillnigga@STUDIO42:~$ sudo apt-get upgrade
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following packages will be upgraded:
    libssl0.9.8 openssl
    2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    4 not fully installed or removed.
    Need to get 3,415kB of archives.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Get:1 http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/main libssl0.9.8 0.9.8k-7ubuntu8.5 [3,015kB]
    Get:2 http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/main openssl 0.9.8k-7ubuntu8.5 [400kB]
    Fetched 3,415kB in 7s (479kB/s)
    Preconfiguring packages …
    (Reading database … 232942 files and directories currently installed.)
    Preparing to replace libssl0.9.8 0.9.8k-7ubuntu8.4 (using …/libssl0.9.8_0.9.8k-7ubuntu8.5_i386.deb) …
    Unpacking replacement libssl0.9.8 …
    Setting up libssl0.9.8 (0.9.8k-7ubuntu8.5) …

    Processing triggers for libc-bin …
    ldconfig deferred processing now taking place
    (Reading database … 232942 files and directories currently installed.)
    Preparing to replace openssl 0.9.8k-7ubuntu8.4 (using …/openssl_0.9.8k-7ubuntu8.5_i386.deb) …
    Unpacking replacement openssl …
    Processing triggers for man-db …
    Setting up dahdi-dkms (1:2.2.1+dfsg-1ubuntu2) …
    Removing old dahdi-2.2.1+dfsg-1ubuntu2 DKMS files…


    Deleting module version: 2.2.1+dfsg-1ubuntu2
    completely from the DKMS tree.


    Done.
    Loading new dahdi-2.2.1+dfsg-1ubuntu2 DKMS files…
    First Installation: checking all kernels…
    Building only for 2.6.31-11-rt
    Building for architecture i686
    Building initial module for 2.6.31-11-rt

    Error! Bad return status for module build on kernel: 2.6.31-11-rt (i686)
    Consult the make.log in the build directory
    /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/ for more information.
    dpkg: error processing dahdi-dkms (–configure):
    subprocess installed post-installation script returned error exit status 10
    dpkg: dependency problems prevent configuration of dahdi-linux:
    dahdi-linux depends on dahdi-dkms | dahdi-source; however:
    Package dahdi-dkms is not configured yet.
    Package dahdi-source is not installed.
    dpkg: error processing dahdi-linux (–configure):
    dependency problems – leaving unconfigured
    dpkg: dependency problems prevent configuration of dahdi:
    dahdi depends on dahdi-linux; however:
    Package dahdi-linux is not configured yet.
    dahdi depends on dahdi-dkms | dahdi-source; however:
    Package dahdi-dkms is not configured yet.
    Package dahdi-source is not installed.
    dpkg: error processing dahdi (–configure):
    dependency problems – leaving unconfigured
    dpkg: dependency problems prevent configuration of asterisk:
    asterisk depends on dahdi; however:
    Package dahdi is not configured yet.
    dpkg: error processing asterisk (–configure):
    dependency problems No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because MaxReports is reached already
    – leaving unconfigured
    Setting up openssl (0.9.8k-7ubuntu8.5) …

    Errors were encountered while processing:
    dahdi-dkms
    dahdi-linux
    dahdi
    asterisk
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    some problems with something called dahdi…..

    #61985

    Strelok
    Participant

    Hmm..it seems an error un-related to the game.
    By typing sudo apt-get upgrade you will install ubuntu updates,which means every program you have will be updated,try to go to system-administration-packet manager and just install scorched 3d updates.
    ➡ About Dependency errors:Dahdi needs other packets you didn’t install.

    #61986

    Hiroshima DREAD
    Participant

    yeah it did complain something about that last night..
    i just upgraded from 8.04.
    because i was littlebit afraid if my studio programs would work with this version.
    only found instructions for hardy. how to put reaper to work under linux.

    so now i have to find out what is that dahdi thing……

    thank you for you help honestly!!
    i will get it to work!!

    peace!!

    #61987

    Hiroshima DREAD
    Participant

    @thrax wrote:

    However, the version you are trying to build is out-dated and missing features.

    The source for the most recent version is retrievable from the sourceforge
    database. Instead of solving how to build something that won’t work with
    the current servers, work together and get thing’s sorted for those that want
    to join in with the rest of us.

    im not sure but i think i did try that soundforge link.
    some link worked but it did put the same 42.1….

    #61988

    Hiroshima DREAD
    Participant

    but i will try that sourceforge link again.
    if i could get it to work.

    #61989

    Hiroshima DREAD
    Participant

    so it downloads me a file…and then i extract it.. and i get usr called file.

    i have to admit i dont know what to do with it…
    shiiit i feel like 5years old….reminds me more of the original scorched.

    #61990

    Strelok
    Participant

    https://launchpad.net/ubuntu/+source/dahdi-linux
    It should be this,nothing important.
    If you need it install all the packets if not remove it 😈

    #61991

    Irishbandit
    Participant

    To compile scorched3d you need the dependicies from this post
    http://scorched3d.co.uk/phpBB3/viewtopic.php?f=1&t=5622&p=53498&hilit=compile+g+#p53498

    and the patch from this post just rename the file scorched.patch copy that file into the ./Scorched3D-43.2a-src/scorched folder
    download/file.php?id=4218

    from within the ./Scorched3D-43.2a-src/scorched
    folder at a terminal run

    patch < scorched.patch
    sh autogen.sh –disable-openaltest CXXFLAGS=-lalut
    make
    sudo make install

    If you have any errors then you dont have one of the dependicies installed. You might have to wait untill the update gets done from getdeb.

    #61992

    Hiroshima DREAD
    Participant

    ok i will learn to do this and try.

    thank you O!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.