This topic contains 6 replies, has 0 voices, and was last updated by  Panther30 7 years, 6 months ago.

  • Author
    Posts
  • #7390

    Panther30
    Participant

    st -f ‘../sound/Sound.cpp’ || echo ‘./’`../sound/Sound.cpp
    In file included from ../sound/Sound.cpp:35:
    /usr/local/include/AL/alut.h:52: error: ‘’ has incomplete type
    /usr/local/include/AL/alut.h:52: error: invalid use of ‘ALvoid’
    make[3]: *** [Sound.o] Error 1
    make[3]: Leaving directory `/home/server1/share/scorched/src/client/scorchedc’
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/server1/share/scorched/src/client’
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/server1/share/scorched/src’
    make: *** [all-recursive] Error 1

    That’s the error I got while trying to compile scorched on Fedora 13. This error was giotten during the compie of the downloaded source tarball.

    EDIT:

    problem has been resolved. see steps in my message below

    #62067

    Panther30
    Participant

    configure: creating ./config.status
    config.status: error: cannot find input file: `Makefile.in’

    This error was gotten during the “./confiigure” phase of installing using the source code downloaded from SVN

    #62068

    Irishbandit
    Participant

    Panther are you using the SVN version for your server?
    If so I wouldn’t. I would use the src.zip or src.tar.gz from this link http://sourceforge.net/projects/scorched3d/files/
    That way you don’t get any of the code changes that Gavin might have made since the release. Just an idea.

    #62070

    Panther30
    Participant

    I’m having trouble figuring out chich command line options to use when compiling the following programs from their sources.

    Openal
    WxGTK-2.8.11

    I dont know if there are other prerquisites for scorched that will ned a fresh compile from their source or not. Please let me know what i need to do. had everything working several days ago and didn’t cdocument exactly what i needed to do an now i’m having some issues.

    thanks,

    —Panther30

    EDIT:

    okay no more problems with wxGTK. but… OpenAL…. well i’ve compiled the newest souce and the openal-config no longer exists. and iv’ve tried disabling openaltest. but the error in my first message still shows up when I run make.

    #62071

    Irishbandit
    Participant

    openal-config has been a pain for me since I started building from source. For me to build on ubuntu I have to patch the source first. I will attach the patch, you will need to rename it to scorched.patch. Dont know if this will work on fedora or not. Some one else probably knows a better why to do it.

    patch < scorched.patch
    sh autogen.sh –disable-openaltest CXXFLAGS=-lalut

    make
    -j3
    sudo make install

    *[edit]
    You might look here for other ideas with fedora.
    http://cvs.fedoraproject.org/viewvc/rpms/scorched3d/?sortby=log

    #62072

    Laptops Daddy
    Participant

    @panther30 wrote:

    I dont know if there are other prerquisites for scorched that will need a fresh compile from their source or not.

    arent freealut-devel and openal-devel are separate packages? make sure you have alut.

    this was a complete list of deps last i knew: viewtopic.php?f=1&t=5622&p=53498&hilit=compile+g+#p53498

    i havent compiled in linux in a long while, but ive never had to mess about compiling or patching dependencies – thatd be enough hassle so i wouldnt bother. (windows is usually my main os). i think s3d has always compiled smoothly out of the box for me, except for that gcc 4.3 viewtopic.php?f=6&t=5504&p=52195&hilit=compile+g+#p52195 thing a while back

    #62073

    Panther30
    Participant

    I forgot a step in the install Irish, or your fix probably would have worked for me (I deleted /usr/local/inclued/AL in perparation to recompile opena-soft wish is the same version as the openal packages i installed )

    anways here is what I did

    compiled wxgtk-2.8.11 –with-gtk –disable-shared

    comiled an older version of openal that still had openal-config (probablyunneccessary)

    deleted /usr/local/include/AL (as root through webmin)

    installed openal packages from repository ( and devel package)

    compiled openal-soft from source (same version as the packages I installed above)

    compiled scorched –with-mysql

    and it worked I dont know why I had to go through all these redundant steps to do it, but I’m makingthis post so that i know what seems to work ( i just spent four days installing and uninstalling inux trying to figure all ths out)

    incidentally in the course of the installs i tested an Ubuntu based linux livecd for Mint 9 which kept video crashing on my servers intel graphics but works find on an older laptop i have with SIS mirage graphics. I guess I’ll be using fedora as a sever for quite a bit longer.

    #62069

    Irishbandit
    Participant

    Thats one thing I like about linux, theres usually more than one way to do something. Stick with fedora if its working for you. I use centos for servers, which follows redhats release schedule + 4 to eight weeks. If you want to use a deb based server check out debian or ubuntu server.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.